The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

connection not allowed from this server?

Discussion in 'General Discussion' started by Ivanner, Jun 4, 2004.

  1. Ivanner

    Ivanner Active Member

    Joined:
    Oct 13, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    I'll keep it short:
    We have a server on ISP X with RH 9.
    We have a freshly installed server on ISP Y with RH Enterprise 3.
    We have root password for both servers. Both servers have WHM 9.2.0.
    We want to move all the accounts from ISP X to the new server on ISP Y.

    This is the error we get:
    The remote server XXX.XXX.XXX.XXX unexpectedly terminated the connection. (connection not allowed from this server?)

    Anyone knows how to fix this ? :confused:

    Please help...we're running out of time.
     
  2. Ivanner

    Ivanner Active Member

    Joined:
    Oct 13, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    OK. Thanks everyone for NOT answering.

    We figured out and here is the answer so if somebody runs into the same problem knows how to fix it.

    SSH port on Server X was set to a non-standard port. The move script uses SSH to copy all accounts. We changed back the SSH port to default and everything worked like a charm.

    I hope this helps somebody else.
     
  3. Nic

    Nic Member

    Joined:
    Dec 9, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    thanks

    Thank you so much, Ivanner!
    It worked for me.
     
  4. masterxxx

    masterxxx Registered

    Joined:
    Dec 15, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thank you much bro. You answered your own question. Cool..
     
  5. boyforeigner

    boyforeigner Well-Known Member

    Joined:
    May 18, 2003
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    How you guys change the port on the server ?
    Could you paste here the commands ?
     
  6. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    Please check the following file
    /etc/ssh/sshd_config

    Let me know the status.
     
  7. boyforeigner

    boyforeigner Well-Known Member

    Joined:
    May 18, 2003
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Here it goes:



    # $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 3600
    #ServerKeyBits 768

    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    SyslogFacility AUTHPRIV
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 120
    #PermitRootLogin yes
    #StrictModes yes

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # rhosts authentication should not be used
    #RhostsAuthentication no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes

    #AFSTokenPassing no

    # Kerberos TGT Passing only works with the AFS kaserver
    #KerberosTgtPassing no

    # Set this to 'yes' to enable PAM keyboard-interactive authentication

    # Set this to 'yes' to enable PAM keyboard-interactive authentication
    # Warning: enabling this may bypass the setting of 'PasswordAuthentication'
    #PAMAuthenticationViaKbdInt no

    #X11Forwarding no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #KeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression yes

    #MaxStartups 10
    # no default banner path
    #Banner /some/path
    #VerifyReverseMapping no

    # override default of no subsystems
    Subsystem sftp /usr/libexec/openssh/sftp-server

    AllowTcpForwarding no
     
  8. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    He was using some another port instead of 22, like 3145 or any other. So he edit the file and find out the port.

    If you want to change the port; please use vi editor or any other editors
     
    #8 bijo, Jun 8, 2005
    Last edited: Jun 8, 2005
  9. boyforeigner

    boyforeigner Well-Known Member

    Joined:
    May 18, 2003
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    looks like the problem is not wrong port, because i can copy fine from others server, just from one that I can't. So look like this one is blocked, and i get this error:

    Packaging the account... The remote server xx.xxx.xxx.xx unexpectedly terminated the connection. (wrong port or connection not allowed from this server?)Done
     
  10. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    Hello,

    How did you try to connect ?. Did you try to connect user as root?
    May be the remote server using any other port instead of 22 or the remote system doesn't allow the "root" to direct login.

    Let me know the status.
     
  11. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Also check out the /root/.ssh/known_hosts at the server you are trying to copy from...and verify the key.
     
Loading...

Share This Page