The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Connection refused to port 2087, can not access secure WHM

Discussion in 'General Discussion' started by saj, Apr 22, 2005.

  1. saj

    saj Member

    Joined:
    Nov 6, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    We can not access WHM through 2087. When try telnet x.x.x.x 2087 shows a connection refuesed error.
    Could you please fix the issue. All efforts regarding to solve this issue is very much appreciated.

    We are able to connect via 2086. But all the secure port are ( 2096, 2083, and 2087) are giving connection refused error.

    Thanks in advance ... :)

    Best Regards,
    Saj.
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Saj, sounds like your hosting provider does not have the SSL port setup correctly on their Cpanel box. Open a ticket with them as they are probably just blocking it via the firewall they have installed. The other possibility is that your network is blocking the 2087 port. I have seen this from some of our customers on corporate networks, but typically 2086 was blocked in that case also.
     
  3. saj

    saj Member

    Joined:
    Nov 6, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hi Kris,

    Thanks for your reply. I have checked and could not find any firewall blocking port 2087. I have stoped iptables, portsentry, and apf and try to start cpanel. Cpanel is starting with out any problem. But when I try to start /usr/sbin/stunnel it seems to be started ok. But I cannot see such a process. The stunnel process is binding to port 2087 in ordinary cases. But here I can not start the process. Do you have any Idea, about what is preventing it from starting.

    I have also checked the configuration file of stunnel and could not find any misconfiguration. But I am not much familiar with that file. If you have any idea, please let me know.

    Thanks for your reply again,

    Best Regards,
    Saj.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you run the following are you seeing port 2087 bound?

    netstat -lpn

    If not, then I've seen this happen if you have imaps configured in xinetd. Check for /etc/xinetd.d/imaps, if it exists, edit the file and set Disable = yes then restart xinetd:

    service xinetd restart

    then restart cPanel

    service cpanel restart

    If the port is already bound to stunnel, then the problem lies elsewhere. another idea then is to login to port 2086 non-SSL and regenerate the WHM SSL certificate.
     
  5. saj

    saj Member

    Joined:
    Nov 6, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hi Chirpy,

    Thank You for your excellent advise. We are able to connect to port 2087 now.

    You seems to be an expert in Linux Administration. Keep it up!!!

    -Saj
     
  6. amal

    amal Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    I'm also having the same issue.. :-( But the xinitd is already having that entry .. tried restarting both xinit and cpanel.
    :(
    no firewal rules as well.

    /var/log/messages also shows no error...
     
  7. amal

    amal Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    My issue is fixed.. Some support person recompiled the kernel on my server with some missing option.. which caused stunnel to fail.

    Everything is back to normal now... :)
     
Loading...

Share This Page