Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Consistently large exim queue

Discussion in 'E-mail Discussion' started by cmdln, May 13, 2007.

  1. cmdln

    cmdln Active Member

    Joined:
    Mar 17, 2007
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    151
    My exim queue is just huge all the time. I have started pruning mail from null senders.
    Code:
    exiqgrep -i -f '^<>$' | xargs -n 1 exim -Mrm
    
    While that has helped a bit my queue is still pretty large. I do see some mail in the queue waiting for delivery to local accounts that do not exist. What do I need to be looking for in my config to make those messages bounce automatically?


    Thanks
     
  2. picoleto

    picoleto Member

    Joined:
    Aug 8, 2006
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    151
    Have you already tried changing some of the settiings within your exim.conf?

    The exim conf default is pretty sucky. You might want to take a look at the below settings and change them to something more reasonable.

    auto_thaw = 6d
    ignore_bounce_errors_after = 7d
    timeout_frozen_after = 8
     
  3. cmdln

    cmdln Active Member

    Joined:
    Mar 17, 2007
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    151
    adding sender verify callouts seems to have done the most good for my queue.

    It has gone from an unwieldy 3k to a peek around 300 when sending 15K outbound mails. Most of the time it seems to hover < 30.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice