Continuous Wrong Email From ChkServd

petaglx

Member
Aug 3, 2011
16
0
51
Hello All Experts,

I have previously searched the web and forums as well as this forum over and over and there are a lot of topics similar to my problem on this forum but none of them state my situation exactly.

I am using cPanel/WHM 11.30.1 (Build 4). The problem is I am receiving an email from ChkServd stating that cpsrvd has been failed and it tried to start it automagically. I am receiving this email every 5 minutes. At the time of receiving this email, everything is fine and there is no problem with cPanel and WHM. So it seems this email is either fake or sent wrongly. My server provider says it is completely ignorable but it is annoying to receive such email continuously. I have already tried upgrading with force option but no change.

Any idea will be highly appreciated.
 
Last edited:

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Can you check if you show any errors in /usr/local/cpanel/logs/tailwatchd_log or /usr/local/cpanel/logs/error_log about chkservd service?

Code:
grep -i chkservd /usr/local/cpanel/logs/*
 

petaglx

Member
Aug 3, 2011
16
0
51
Hi.

Sorry for late reply. I did not notify of your reply. I checked and there was no error in any of fiels above regarding cpsrvd or chkservd. Bellow are the content of email it sends out.

Code:
cpsrvd failed @ Thu Aug  4 09:51:17 2011. A restart was attempted automagically.

 Service Check Method:  [tcp connect]

 Failure Reason: cpsrvd: [HTTP/1.1 401 Access Denied != HTTP/1.x 200 OK] [received_key=<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><link rel="shortcut icon" href="/unprotected/cpanel/favicon.ico" type="image/x-icon" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>cPanel&reg; 11</title><link rel="stylesheet" href="/unprotected/cpanel/style_optimized.css" type="text/css" /><meta name="robots" content="noindex, nofollow" /></head><body><div id="wrap"> <div id="top-whm">                      </div>  <div id="mid">          <div id="content-wrap" align="center"> <form action="/login/" method="post" >    <input type="hidden" name="login_theme" value="cpanel" />    <table width="200px" class="login" cellpadding="0" cellspacing="0">        <tr>            <td align="left" colspan="2"><strong>Login</strong></td>        </tr>        <tr>            <td class="login_lines">Username&nbsp;</td>            <td class="login_lines"><input autofocus="autofocus" type="text" id="user" name="user" size="16" /></td>        </tr>        <tr class="row2">            <td class="login_lines">Password&nbsp;</td>            <td class="login_lines"><input type="password" id="pass" name="pass" size="16" /></td>        </tr>        <tr>            <td colspan="2" style="text-align: center"><input type="submit" id="login" value="Login" class="input-button" /></td>        </tr>    </table>    <input type="hidden" name="goto_uri" value="/.__cpanel__service__check__./serviceauth?sendkey=UOcZtqSKlnlnAAnZUhRw5kBEFrHsyiCFRSp3YyNkt07ff2miz2WKKPUPIE1QBYFv&amp;version=1.2" />    <input type="hidden" name="reset_tokens" value="0" /></form><script type="text/javascript">//<![CDATA[   document.getElementById("user").focus();/* Must not include external javascript -jnk 06.20.09 *///]]></script></div></div><div id="bot-whm"></div>&copy; cPanel, Inc. 2011</div></body></html>] [expected_key=GGFQFCgykfUSQEGYGLB2RkatxeoB9c39k4pBjJ64iio166jap6UMB9GdxboCoLRE]


 Number of Restart Attempts: 1916
Most likely chkservd involves into login problem when checking cpsrvd status. I hope you can find out the reason.

Many Thanks.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
The only instance I've seen of a similar error was when 127.0.0.1 was reporting as the main IP rather than loopback device, so when querying 127.0.0.1, the main IP was shown for routing instead.

You can test this to see if that's the case by doing:

Code:
curl 127.0.0.1
In another window while doing that, check this log:

Code:
tail -fn0 /usr/local/apache/logs/access_log
You'll be looking for a line like the following:

Code:
127.0.0.1 - - [04/Aug/2011:10:24:10 -0400] "GET / HTTP/1.1" 200 111
If instead of seeing that you see something this:

Code:
mainIP# - - [04/Aug/2011:10:23:55 -0400] "GET / HTTP/1.1" 200 111
Where mainIP# is the server's main IP number, then you'll need to look into the routing on your machine. We cannot assist with fixing routing issues. Your datacenter, NOC or provider should be able to help instead at that point. The basic gist of the issue will be that 127.0.0.1 isn't responding as localhost but as the main IP, which shouldn't happen.
 

petaglx

Member
Aug 3, 2011
16
0
51
Hi.

I did that and got the following two lines in the log while running the curl.

Code:
MainIP - - [04/Aug/2011:21:43:08 +0000] "GET / HTTP/1.1" 200 111
MainIP - - [04/Aug/2011:21:43:18 +0000] "OPTIONS * HTTP/1.0" 200 -
I know there is no problem with my data center network or resolver. It is certainly an internal routing problem with my server. Please let me know if you know any soluton either iptbles or other networking service. I am using CentOS 5.4 and cPanel 11.30.2 (Build 1) with iptables enabled.

Many Thanks.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
I don't know what is wrong with your routing on the machine, but something is wrong. If you want to post the output of "ifconfig" on the machine for us to see if we spot anything, please let us know.

Also, you might want to provide the output for /etc/hosts file to see if you have localhost improperly set to something other than 127.0.0.1 on it.
 

petaglx

Member
Aug 3, 2011
16
0
51
Hi.

The following lines in ifconfig prooves that 127.0.0.1 is used as loopback.

Code:
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:319909 errors:0 dropped:0 overruns:0 frame:0
          TX packets:319909 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:50617566 (48.2 MiB)  TX bytes:50617566 (48.2 MiB)
Also the following line in /etc/hosts confirms the above:

Code:
127.0.0.1               localhost
I hop this can help.

Many Thanks.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
We would need the full ifconfig and /etc/hosts rather than just the portions that are right to see if something isn't correctly configured. Truncating the output will make it more difficult to resolve the issue.

Please also provide the output for these commands where output means the full output:

Code:
route -n
/sbin/iptables -n -L
Thanks!
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
You'll probably want to open up a ticket then if the above numerous details and steps don't fix the issue for you. A ticket can be submitted via WHM > Support Center > Contact cPanel or using the link in my signature. Thanks!
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Are you using WHM > Support Center > Contact cPanel or another method?

If you continue having issues submitting a ticket, please email [email protected] directly and let them know the issue you had submitting a technical support ticket. They can route the ticket to the right location.