The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Copy an account from another server (Plesk->cPanel) error

Discussion in 'Migrate to cPanel' started by sunmacet, Mar 15, 2012.

  1. sunmacet

    sunmacet Member

    Jan 24, 2009
    Likes Received:
    Trophy Points:

    When I try to transfer one account from Plesk 8.6 to our cPanel 11.30.6 but I always get following error:

    Attempting to copy test from xx.xx.xx.xx
    Creating /scripts... Done
    Copying pkgacct-pXa script.....0%.. ..100%.. ...Done
    Copying unpkgacct script.....0%.. ..100%.. ...Done
    Packaging the account: (/scripts/pkgacct test "" --split --compressed --mysql 5.1)...
        MySQL error: ERROR 1045 (28000): Access denied for user 'admin'@'localhost' (using password: YES) at /tmp/.perl-ppk-YASSzM/scripts/ line 1671.
    5.07 TB free, need 0 Bytes
    Warning: file location not sent.. guessing.. this may not work ....
    Using the single archive method (/home/cpmove-test.tar.gz)!
    Copy Destination: /home
    Transfer Error
    The remote server didn't report a correct md5sum of the archive. Please ensure you selected the correct type of remote server.
    Removing Copied Archive on remote server.... Done
    I have tried multiple times. Also I have tried transfer from another Plesk server with same error. Also I have tried the multiple transfer system but it fails with same error.

    In source server the admin can login to MySQL without problems. I have also tried to change root password to admin password in the MySQL and use it in the transfer but no help.

    This doesn't make any sense to me. I have tried to find any answers from Google but none I have found about this kind of issue.

    Any help or ideas where to look would be greatly helpfull. Thank you!
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    This is likely due to a recent bug in our transfer tool used for migrations from Plesk. It's corrected in the development version of our Pkgacct script, and that fix should make it's way to the public version in the coming days. In the meantime, you should be able to correct this by running the following command on the Plesk machine:

    echo -e "[client]\nuser=admin\npass='`cat /etc/psa/.psa.shadow`'" > /root/.my.cnf
    Thank you.

Share This Page