Copying php 5.6 from another CPanel server

microvax

Active Member
Mar 4, 2021
28
1
3
Lima
cPanel Access Level
Root Administrator
Recently installed a new server with WHM version v96.0.11
and noticed that php 5.6 is no longer available
so I was wondering if it is possible to copy it from another server
that has it installed
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,440
1,004
313
cPanel Access Level
Root Administrator
@microvax - it's definitely more secure to use the CloudLinux version if you need to run older versions of the PHP software.

However, I created a build just now on 96.0.11 and I do see all the versions available in EasyApache. We have the full list of what is supported here:


Are you saying you aren't able to install those through EasyApache at this time?
 

vacancy

Well-Known Member
Sep 20, 2012
474
165
93
Turkey
cPanel Access Level
Root Administrator
If you are using Centos 7 you can add it via easyapache 4. If you are using centos 8 or almalinux 8 you cannot use versions below 7.2. You need to use Cloudlinux.
 
  • Like
Reactions: cPRex

microvax

Active Member
Mar 4, 2021
28
1
3
Lima
cPanel Access Level
Root Administrator
Do you know if CloudLinux OS 8.4 is yet released for production?

If you are using Centos 7 you can add it via easyapache 4. If you are using centos 8 or almalinux 8 you cannot use versions below 7.2. You need to use Cloudlinux.
I am running the command "sh cldeploy -i"
but I am receiving this error message

[email protected] [~]# sh cldeploy -i
Checking for an update to cldeploy
Downloading version.dat (please wait)
cldeploy is already the latest version (1.76) - continuing
WARNING: Your AlmaLinuxOS release version is greater than currently available CloudLinux release!
You can wait for new CloudLinux release or downgrade your
AlmaLinuxOS installation to previous minor release and then run conversion to CloudLinux again.

To continue conversion anyway, you may run conversion with --skip-os-release-check option.
WARNING: There are no guarantees that it will not cause any system issues after conversion
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,440
1,004
313
cPanel Access Level
Root Administrator
That error message is just letting you know that your AlamLinux packages are already updated past the CloudLinux packages. Since CloudLinux performs additional security hardening and testing, they may run a few days behind the latest releases.

It would be good to reach out to them directly for official details on that, or wait a few days and try the work again.