Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Could not connect to SMTP host

Discussion in 'E-mail Discussions' started by Nirjonadda, Jan 10, 2018.

  1. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    574
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Why I am can not send email ? SMTP Error: Could not connect to SMTP host. we are using mailgun.com for sending email. My SMTP Settings is Server: smtp.mailgun.org, ports 25, Encryption: TLS/SSL. I can confirm that email sending work Encryption: unsecured, So how server secure connection work?

    Code:
    [E_WARNING] stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like the SMTP connection attempt was made using weak ciphers. Check to see if the solution on the following post works if you want to allow those connections (not recommended due to the decreased security):

    Outlook 2016 Sending Email Fails After Cipher Suite Update

    Thank you.
     
  3. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    574
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator

    No, Still are not work Encryption: TLS/SSL. This issue happened after moved to new server.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Did you try the other workarounds referenced on that thread, or did you only adjust the weak ciphers option?

    Thank you.
     
  5. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    574
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I think we have fixed this issue with CSF installation.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm glad to see you were able to find a solution. Feel free to let us know the specific change you made in your CSF configuration.

    Thank you.
     
  7. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    574
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Installed CSF and allowed port 25 but before port 25 where are blocked for secure connection?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hi,

    Thank you for sharing the outcome. It likely relates to the same issue referenced on the following third-party URL since it applies to a smart host configuration:

    Configure CSF to allow outbound SMTP

    Let us know if you encounter any additional issues.

    Thank you.
     
Loading...

Share This Page