Could not create a new account: WHM

OppaOppa

Member
Dec 10, 2015
8
0
51
Nepal
cPanel Access Level
Root Administrator
Namaste!
I have recently setup a VM and have installed cpanel successfully.

I also have created additional domain in the server but while creating third domain, I am getting error.

When i try to create a new account from whm (root login), i get:
"A fatel error or timedout occured while processing this directive. [show]"

This error is displayed in background and in lightbox or popup screen i can see:
"Adding Entries to httpd.conf", in new account creation process and nothing happens. I tried multiple times to create new account.

Now the strange part is, after seeing this error, if i try to create a new account again with same domain; i get following error:

"
Account Creation Status: failed
(XID jbqjhs) A DNS entry for “example.com” already exists. You must remove this DNS entry from all servers in the DNS cluster to proceed.
"

Now I go to "Delete a DNS Zone", and delete the dns zone for the domain i was trying to create account. And again try to create the account. I get following error:
"
Account Creation Status: failed

(XID sfsftb) This system already has an account named “example”.
"

Now this makes no sense, as cpanel was not able to create a new account and now first it said dns exists but no account was available. After I delete dns zone for the domain, then account appears in the account list. Finally deleting the account from the list, I am able to go to create a account option and repeat the process.

I have repeated this process of deleting dns zone and account for multiple times and tried to create account but with zero successes.

I have attached the first error i face while creating a new account.

I need urgent help.
 

Attachments

jlucho

Well-Known Member
Aug 5, 2006
85
1
158
first repair fix quota with : /scripts/fixquotas

Then review that you have not created that domain before, see . WHM -> DNS FUNCTIONS -> DELETE DNS ZONE

If you can see the domain, delete

Then re-create it with CREATE ACCOUNT