The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

counter error

Discussion in 'General Discussion' started by rivtech, Apr 2, 2002.

  1. rivtech

    rivtech Registered

    Joined:
    Mar 21, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Can anyone give me a clue why this error occurs?

    My webhost doesn't support cpanel, even though it comes with the plan I paid for, but they say they work on bugs and troubles.

    I would think this is caused by something they could reconfigure.

    Or please point me in a different direction.

    could not write to counter file:/var/cpanel/Counters/rivtechindex.dat

    any help would be appreciated.
    Vicki
     
  2. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    chown it to nobody and see if that helps.

    /chown nobody.nobody /var/cpanel/Counters/rivtechindex.dat
     
  3. knipper

    knipper Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Hi Vicki,

    You are probably getting this after enabling suExec on the server. (Unfortunately if you have enabled suExec and had a number of domains with counters previously none of them will be working)

    Goto /var/cpanel/Counters then you need to chown the file to the user.

    chown username.username FILENAME

    In the example you showed it shoud be:
    chown rivtechindex.rivtechindex rivtechindex.dat

    That will get their counter working again. ;)

    I just had to do this for about 15 sites on my server.
     
  4. maxhost

    maxhost Well-Known Member

    Joined:
    Jan 30, 2002
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    hi knipper
    have the same problem afhter enable suexe on a server...
    but what happens if i now disable suexe..? will they starting to work ?

    or can i fixe the problem using
    Fix insecure permissions on cgi scripts. (requires suexec)
    in the WHM ?

    Thanks
     
  5. miami_g

    miami_g Active Member

    Joined:
    Dec 28, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    i have the smae issue for old counters and new ones dont function either???

    any ideas re the new ones, cant chown every new user that decides he wants a counter...
     
  6. jen

    jen Registered

    Joined:
    May 6, 2002
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello. I am new here and have searched high and low for an answer to my own counter problems, and this thread is the closest I've gotten.

    I am a personal user (I use CPanel through sterlet.net) and I received the same error message when I first tried installing my counter (could not write to counter file:/var/cpanel/Counters/hudson20.dat).

    There are no directions on the site (other than the FAQ stating that the preloaded cgi scripts should all work automatically once you configure them) and support for CPanel apps are nonexistent. I mucked around with the html and eventually got rid of the error message but now have a red X in the frame where my counter should be:

    http://www.hudson2001.com/testvalentineindex.html

    I assume it has something to do with the hudson20.dat file, but I have no idea what it is, if I'm supposed to create it, if it's supposed to have been created automatically, where it's supposed to go, or what?!?!?

    I read the suggestions listed here, but I have no idea what chown or suexe are. Like I said, I am a personal user and not an admin (well, I guess I'm the admin of my own site). If anyone could help me figure this out, I'd be very grateful, as I hate it when I can't figure something out on my own.

    Much thanks.
     
  7. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca
    i fixed this problem for rivtech.

    when suexec is enabled the file needs to be owned by the user who runs it. chown the counter files to the specified users or i beleive you can chown them all to nobody and set the perms to 755. The best most secure thing to do would be to set them to be owned by the user who uses them. If any of you want some more in detail help email me or AIM me
     
Loading...

Share This Page