The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Couple of Questions, and some ip problems

Discussion in 'General Discussion' started by damainman, Dec 3, 2003.

  1. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    Okay in WHM i set a ip address to be used for sharing, for the virtual hosting:

    xx.xx.xxx.101

    Now I set up two accounts in WHM, when i view the account info they are both registered to xx.xx.xxx.101 .... but when i go to xx.xx.xxx.101/~user nothing happens.

    Now my primary name servers is xx.xx.xxx.103.

    I let about 4 hours go by after i set up the two previous accounts, just to see if time would fix the problem... so i went back to test but i accidently put xx.xx.xxx.103/~user instead of xx.xx.xxx.101/~user .... and it worked. So my users are able to view their site not by adding /~user to the ip that i assigned to them as shared.... but by adding /~ to the ip of my primary name servers


    - My users are assigned to xx.xx.xxx.101 ... but their account can only be viewed at xx.xx.xxx.103 which is the ip for my primary servers....Does anyone know why?

    - Now when i put to xx.xx.xxx.103/~user the url in the browser changes to server.myhost.com/~user << is that how its suppose to work?


    Another question i had is.... when i assign a ip to share for virtual hosting.. do i need to assign a domain to it as well? I'm asking this because the first account i sign to that ip.... its like that account takes hold of the ip... and when i view the ip.. i see the folders and everything for that domain......


    - Also in WHM in "Software/RPM's to install" it has a list of packages. Are the only packages installed the ones that say reinstall next to them? {ieackagename(reinstall)}

    - Has anyone done a graceful or forceful reboot on cpanel without problems? Any insight or recommendations other then using this?

    Thank you in advance
     
  2. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    Okay i just did a quick test on .. /~user/ << that works no matter which ip i use it on... is that suppose to happen? or is it only suppose to work on the ip i setup for the Main Shared Virtual Host IP.

    I made an error on my post above... i ment that /~user (without the forward slash) is accesable by using the ip of my secondary nameservers... not my primary.
     
  3. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    Offtopic:

    I went in WHM and under IP functions, i clicked on Show IP Address Usage.. and i noticed it lists one of my ips twice. So then i clicked on Show or Delete Current IP Addresses... and the same ip is showed twice......... its the ip used on my secondary nameservers...... any one of an idea why this is the only ip showing twice.. and should i delete the duplicate entry?
     
  4. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
Loading...

Share This Page