Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

courier-imap loads itself in cpanel upgrading process

Discussion in 'General Discussion' started by mapg, Nov 11, 2005.

  1. mapg

    mapg Member

    Joined:
    Dec 9, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    BUG: courier-imap loads itself in cpanel upgrading process

    Hi all,

    Well, I am having a problem with courier-imap.

    When I upgraded to latest stable version of Cpanel x86 for a Red Hat 9 Box, courier-imap loaded itself and started to run. Take in consideration that I haven't any imap service enabled in WHM Service Manager, neither uw-imap nor courier-imap.

    The hosting admin team tried to force a new cpanel upgrading again, and courier-imap auto-loaded again too.

    The worst thing of this is that courier-imap SSL daemon takes HTTP SSL Ports of WHM while exim and cpop is running at the same time (uw-imap not. Any imap dameon is disabled as I mentioned). The only way to recovers these HTTP SSL Ports is stopping courier-imap and courier-authlib and restarting Cpanel.

    My question is... where is the config file of Cpanel that loads courier-imap again and again when WHM/Cpanel is upgraded despite nobody enabled this daemon to run?

    To do mention that I used the script to convert uw-imap to courier-imap one month ago more and less (when Cpanel team informed that there was a security hole), but as it was solved and I didn't like to count with so many daemons running as courier-imap has, I downgraded to uw-imap again.

    I always use stable versions of Cpanel and chkservd.conf file doesn't load any imap service.

    I never had a problem using stable versions, but this imap daemon conversion has been a really bad thing according to what I see in these Cpanel forums. Now, this courier-imap want to survive itself as an errant phantom despite I do not want not even see it :-(

    Regards

    Mapg
     
    #1 mapg, Nov 11, 2005
    Last edited: Nov 12, 2005
  2. Bash

    Bash Member

    Joined:
    May 7, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    151
    Hi Mapg,

    Let me know if you find out why, I'm still trying to determine what is causing this to happen.

    Thank you,

    -Bash
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice