Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Courier imap timeout

Discussion in 'General Discussion' started by linuxdude, Oct 27, 2005.

  1. linuxdude

    linuxdude Member

    Joined:
    Feb 16, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    151
    Did the maildir conversion recently. But Courier Imap seems to timeout every 60 secs. I did try to see if I can set the timeout limit in /usr/lib/courier-imap/etc/ but couldn't find a way to do it. Any help in this matter is appreciated.
     
  2. hillbilly1980

    hillbilly1980 Member

    Joined:
    Apr 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    151
    I would love to get some help doing this too. We have the exact same issue every 60 seconds.
     
  3. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    Did you re-inctall/upgrade exim using: /scripts/eximup --force after the conversion? You can also re-build courier by runng this command: /scripts/courierup --force
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. hillbilly1980

    hillbilly1980 Member

    Joined:
    Apr 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    151
    it's not broken it's timeing out. The operations are for rather large folders, it gets to 60 seconds and dies cause of the time out. I don't need to rebuild it cause it's working fine other wise i just need to know where to up this 60 second thing.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    No, no need to rebuild/reinstall anything.

    It could be this setting in /usr/lib/courier-imap/etc/imapd

    IMAP_IDLE_TIMEOUT=60

    You could try doubling that and then restarting courier:

    /scripts/restartsrv_courier
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. hillbilly1980

    hillbilly1980 Member

    Joined:
    Apr 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    151
    I'm on freebsd 5.4 i don't have this folder

    /usr/lib/courier-imap
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    You'll have to go hunting for it then ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. hillbilly1980

    hillbilly1980 Member

    Joined:
    Apr 25, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    151
    Inetd.conf is actually what is spawning imapd, from this line.

    /usr/local/cpanel/3rdparty/bin/imapd

    any idea where the config file would be for this?
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice