The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cP Release update overwriting cP php.ini w/reg_globals ON

Discussion in 'General Discussion' started by MaraBlue, May 28, 2008.

  1. MaraBlue

    MaraBlue Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    cPanel Access Level:
    Root Administrator
    cP Release update overwriting cP php.ini w/reg_globals ON [solved]

    The last 2 cPanel updates, to 11.18.6-RELEASE_24654 and 11.23.1-RELEASE_24893 have overwritten the cPanel php.ini (/usr/local/cpanel/3rdparty/etc/php.ini) and changed the register_globals back to ON (I had them OFF).

    I verified they were off, took screen shots, upgraded cPanel, then checked and cPanel's PHP register_globals are back on (and my comments were deleted from php.ini, so it's being replaced).

    I can't for the life of me figure why cPanel would want register_globals on (again, this is for cPanel's own internal PHP, but it shouldn't need register_globals on, nor want it).

    Am I missing something, or is this a bug?
     
    #1 MaraBlue, May 28, 2008
    Last edited: May 29, 2008
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Did you turn off register globals in Tweak Settings?
     
  3. MaraBlue

    MaraBlue Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    cPanel Access Level:
    Root Administrator
    Epppp...you kids and your GUI settings. I didn't know there was a setting in WHM, I changed it with vi.

    In "Tweak Settings" there is: cPanel PHP Register Globals (Off is recommended for security reasons), and it's checked. I have to say the wording there isn't too clear, but I'll assume that checked == ON, so I'll uncheck it and see what happens.

    Thanks for the reply!

    EDIT: Apparently it's *not* cPanel overwriting cPanel's php.ini...it's Fantastico.

    http://www.netenberg.com/forum/index.php?topic=6569.0

    From Fantastico's admin panel in WHM:

    Fixed: "register_globals" Bug - http://www.netenberg.com/forum/index.php?topic=6569.0
    Fantastico will add to or create /scripts/postupcp if it doesn't exist. We are adding code which will re-enable register_globals only on the backend copy of PHP that is used solely for cPanel and WHM. An upcoming release of Fantastico will remove this code and turn off register_globals.

    *sigh*
     
    #3 MaraBlue, May 29, 2008
    Last edited: May 30, 2008
  4. bhd

    bhd Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    JNB ZA
    cPanel Access Level:
    Root Administrator
    Yeah, that had me going for a while too. To have it "off" it seems it must be unchecked. The wording is ambiguous.
     
  5. MaraBlue

    MaraBlue Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    cPanel Access Level:
    Root Administrator
    Glad it's not just me :)

    Seems it's Fantastico overwriting the internal php.ini.
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    The wording has been adjusted in the latest release.
     
  7. MaraBlue

    MaraBlue Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    cPanel Access Level:
    Root Administrator
    Wow, that's awesome. Thanks!
     
Loading...

Share This Page