The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPaddons errors

Discussion in 'General Discussion' started by crashish, Feb 12, 2009.

  1. crashish

    crashish Registered

    Joined:
    May 18, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I tried searching around a bit for the errors I'm encountering but didn't find anything, so I hope this hasn't been covered elsewhere.

    While trying to install cPaddons from a user's cPanel, only the basic version information pops up. For example, on the WordPress page, all that appears is this:
    Code:
    This is a cPanel packaged module. (v0.4)
    
    Website http://www.wordpress.org/
    Since none of the install/config stuff that usually appears was showing up, I took a look into the cPanel error logs, and each time a cPaddon page is loaded, the following is logged:

    Code:
    2009-02-12 23:11:54 notice [cPAddons] UID '$>' can't write storable file '$file', not converting to yaml, simply returning data at /usr/local/cpanel/Cpanel/cPAddons.pm line 2878
            Cpanel::cPAddons::_read_cache('/var/cpanel/cpaddons_moderated', HASH(0x2be6130)) called at /usr/local/cpanel/Cpanel/cPAddons.pm line 98
            Cpanel::cPAddons::cPAddons_init() called at (eval 74) line 1
            eval 'Cpanel::cPAddons::cPAddons_init();' called at cpanel.pl line 4909
            main::modloader('cPAddons') called at /usr/local/cpanel/Cpanel/LoadModule.pm line 10
            Cpanel::LoadModule::loadmodule('cPAddons') called at cpanel.pl line 1618
            main::exectag('<cpanel cPAddons="mainpg(%FORM)">') called at cpanel.pl line 4742
            main::dotag(undef) called at cpanel.pl line 4625
            main::cpanel_parseblock(SCALAR(0x218a9f0)) called at cpanel.pl line 4577
            main::cpanel_parse(GLOB(0x2678110)) called at cpanel.pl line 1303
    2009-02-12 23:11:54 die [Cpanel::DataStore] Could not open() file '/home/cpusers/emiles/.cpaddons/cPanel::Support::cPSupport.0.yaml' for reading: Permission denied at /usr/local/cpanel/Cpanel/DataStore.pm line 89
            eval {...} called at /usr/local/cpanel/Cpanel/DataStore.pm line 48
            Cpanel::DataStore::load_ref('/home/cpusers/emiles/.cpaddons/cPanel::Support::cPSupport.0.yaml', HASH(0x2d4a930)) called at /usr/local/cpanel/Cpanel/cPAddons.pm line 2897
            Cpanel::cPAddons::_read_cache('/home/cpusers/emiles/.cpaddons/cPanel::Support::cPSupport.0', HASH(0x2d4a930)) called at /usr/local/cpanel/Cpanel/cPAddons.pm line 759
            Cpanel::cPAddons::_handlemod(1, 'cPanel::Blogs::WordPress', '693ee2c33807923db77b8cf2592ec2ef', HASH(0x2179c50)) called at /usr/local/cpanel/Cpanel/cPAddons.pm line 348
            Cpanel::cPAddons::cPAddons_mainpg(HASH(0x2179c50)) called at (eval 79) line 1
            eval 'Cpanel::cPAddons::cPAddons_mainpg(@{$argref});' called at cpanel.pl line 1637
            main::exectag('<cpanel cPAddons="mainpg(%FORM)">') called at cpanel.pl line 4742
            main::dotag(undef) called at cpanel.pl line 4625
            main::cpanel_parseblock(SCALAR(0x218a9f0)) called at cpanel.pl line 4577
            main::cpanel_parse(GLOB(0x2678110)) called at cpanel.pl line 1303
    
    This seems to occur with all the latest versions of STABLE, RELEASE, and CURRENT. EDGE will show the install/config section, and will allow installs to take place, although the installs are somewhat broken. I tried WP and the username/password I specified did not work. The uninstall feature does not work at all. Also, on EDGE I am seeing a lot of [an error occurred while processing this directive] tags in cPanel.

    Any input would be greatly appreciated.
     
  2. crashish

    crashish Registered

    Joined:
    May 18, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    So, with my terminal wrapping lines, I didn't notice initially that there were two log entries there. The second entry, being a permissions error, was simple enough to fix, but the first error still remains. At the very least, with the permissions error fixed on the .yaml files, users can proceed with addon installs. Seeing that it's trying to load the cPSupport yaml file is confusing, though, since the addon I was testing was WordPress...
     
  3. stevenc317

    stevenc317 Well-Known Member

    Joined:
    Jan 27, 2009
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    I am as well having problems with the WordPress cPaddon and am currently working with the techs (support ticket #378637)

    "I am going to discuss this with Dan in our development team who handles the
    cPAddons system. Once I hear back from him I will let you know.

    Thank you.
    --
    Kyle Pinkley
    cPanel Technical Analyst III"
     
  4. manuk

    manuk Active Member

    Joined:
    Jul 6, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    6
    same problem here with wordpress !
     
  5. stevenc317

    stevenc317 Well-Known Member

    Joined:
    Jan 27, 2009
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    I have been talking with one of the Developers (Daniel Muey) and he is in the process of fixing this, I am sure they'll make it a global fix when it is done.
     
Loading...

Share This Page