jndawson

Well-Known Member
Aug 27, 2014
303
32
78
Western US
cPanel Access Level
DataCenter Provider
Customer having issues with installing WP via cPAddons. I went to WHM:
cPanel » Install cPAddons Site Software

And ended up with this on the page and only this:

Code:
 Install cPAddons Site Software
[B]Installed[/B] [B]Vendor[/B] [B]Category[/B] [B]Name[/B] [B]Version[/B]
cPanel Blogs WordPress 4.5.3
That's it, except for the checked box preceding 'cPanel Blogs'. No other buttons, no other software listed. We have a few customers have installed other cPAddons but those are not listed on the 'Install cPAddons Site Software' page.
 
Last edited by a moderator:

jndawson

Well-Known Member
Aug 27, 2014
303
32
78
Western US
cPanel Access Level
DataCenter Provider
We now have 2 cpanel boxes where the abbreviated page displays, and 1 where it's correct.

We can not see anything that would cause this. Is anybody else seeing this?

Update:

We ran
Code:
/scripts/cpaddonsup --force
with no effect.

We ran
Code:
/scripts/synccpaddonswithsqlhost
And after running through a few accounts, we got this error:
Code:
Can't locate md5_fallback.pm in @INC (you may need to install the md5_fallback module) (@INC contains: /usr/local/cpanel/cpaddons /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/5.22.1/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/5.22.1 /opt/cpanel/perl5/522/site_lib/x86_64-linux-64int /opt/cpanel/perl5/522/site_lib) at /usr/local/cpanel/cpaddons/cPanel/Ecommerce/OSCommerce.pm line 14.
Compilation failed in require at /scripts/synccpaddonswithsqlhost line 86.
What is the 'md5_fallback module'? We apparently have 2:
Code:
[ [email protected] named># locate md5_fallback.pm
/usr/local/cpanel/cpaddons/cPanel/Bulletin_Boards/YaBB/md5_fallback.pm
/usr/local/cpanel/cpaddons/cPanel/Ecommerce/OSCommerce/md5_fallback.pm
Anybody else with this issue?
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Customer having issues with installing WP via cPAddons. I went to WHM:
cPanel » Install cPAddons Site Software

And ended up with this on the page and only this:
Hello,

I'm unable to reproduce this issue. Could you let us know the version of cPanel installed on the system, and also let us know if forcing a cPanel update via "/scripts/upcp --force" makes a difference? In addition, would you mind attaching a screenshot of what you see in the interface?

Thank you.
 

jndawson

Well-Known Member
Aug 27, 2014
303
32
78
Western US
cPanel Access Level
DataCenter Provider
Hello,

I'm unable to reproduce this issue. Could you let us know the version of cPanel installed on the system, and also let us know if forcing a cPanel update via "/scripts/upcp --force" makes a difference? In addition, would you mind attaching a screenshot of what you see in the interface?

Thank you.
See attached screen shots of all 3 of our boxen. We are running "/scripts/upcp --force" and will provide results when complete because it's taking years to complete.

risp_scrnshot_cpaddons_cp1.png risp_scrnshot_cpaddons_cp2.png risp_scrnshot_cpaddons_cp3.png

UPDATE: No change after running "/scripts/upcp --force".
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

Internal case CPANEL-7645 is open to address an issue where after enabling all scripts in "WHM >> Install cPAddons Site Software" on cPanel version 58, browsing to this option again results in a single listing for WordPress in the interface. In addition, an error message like this is output to /usr/local/cpanel/logs/error_log:

Code:
warn [cpsrvd] The subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/cpaddons.pl) exited with an error: The subprocess reported error number 2 when it ended. at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 156.
I'll update this thread with more information on case CPANEL-7645 as it becomes available.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

The resolution associated with CPANEL-7645 is released as part of cPanel version 58.0.13:

Fixed case CPANEL-7645: Wrap individual cPAddon install require's in evals.

This version is currently published to the "Edge" and "Current" build tiers, and is tentatively scheduled for publication to the "Release" build tier tomorrow. You can review the full change log, information on updating cPanel/WHM, and information on the build/release process at:

58 Change Log - Change Logs - cPanel Documentation
How can I update cPanel & WHM?
Product Versions and the Release Process - cPanel Knowledge Base - cPanel Documentation

Thank you.
 

jndawson

Well-Known Member
Aug 27, 2014
303
32
78
Western US
cPanel Access Level
DataCenter Provider
Hello,

The resolution associated with CPANEL-7645 is released as part of cPanel version 58.0.13:

Fixed case CPANEL-7645: Wrap individual cPAddon install require's in evals.
Looks like we have the page(s) back. Now we have this in 2 of the cPanel-supplied scripts:
Code:
Error loading YaBB: Can't locate md5_fallback.pm in @INC (you may need to install the md5_fallback module) (@INC contains: /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi /usr/local/cpanel/cpaddons /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/5.22.1/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/5.22.1 /opt/cpanel/perl5/522/site_lib/x86_64-linux-64int /opt/cpanel/perl5/522/site_lib) at /usr/local/cpanel/cpaddons/cPanel/Bulletin_Boards/YaBB.pm line 9. Compilation failed in require at /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons.pl line 382.
And
Code:
Error loading OSCommerce: Can't locate md5_fallback.pm in @INC (you may need to install the md5_fallback module) (@INC contains: /usr/local/cpanel /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi /usr/local/cpanel/cpaddons /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/5.22.1/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/5.22.1 /opt/cpanel/perl5/522/site_lib/x86_64-linux-64int /opt/cpanel/perl5/522/site_lib) at /usr/local/cpanel/cpaddons/cPanel/Ecommerce/OSCommerce.pm line 14. Compilation failed in require at /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons.pl line 382.
What are we all missing?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Error loading YaBB: Can't locate md5_fallback.pm in @INC (you may need to install the md5_fallback module)
Hello,

An additional case, CPANEL-7786, will address this error message. I will update this thread once it's released.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello @jndawson,

To update, CPANEL-7786 is now fixed. Please verify you are using the latest version of both OSCommerce and YaBB (Mod Note: Removed Specific Version Numbers), and let us know if the issue persists.

Thank you.
 

jndawson

Well-Known Member
Aug 27, 2014
303
32
78
Western US
cPanel Access Level
DataCenter Provider
Hello @jndawson,

To update, CPANEL-7786 is now fixed. Please verify you are using the latest version of both OSCommerce and YaBB (0.55 and 0.7), and let us know if the issue persists.

Thank you.
Here's what we have in Install cPAddons Site Software:
Code:
cPanel Blogs WordPress 4.6.1
cPanel Bulletin Boards YaBB 2.3.1
cPanel Bulletin Boards phpBB3 3.1.9
cPanel CMS E107 1.0.4
cPanel Ecommerce AgoraCart 5.2.005-index-fix
cPanel Ecommerce OSCommerce 2.3.4
cPanel Gallery Coppermine 1.5.44
Not sure where the 'OSCommerce and YaBB (0.55 and 0.7)' version is found, or why it's radically different than what we have.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

Those versions are the most recent available (YaBB 2.3.1 and OSCommerce 2.3.4). I've been unable to reproduce this issue on a test system. Could you verify you are using cPanel version 58.0.31, and that uninstalling/installing the cPAddons doesn't resolve the issue? Also, if the issue persists, make sure you enable "Force Refresh of All cPAddons Site Software Sources".

Thank you.
 

jndawson

Well-Known Member
Aug 27, 2014
303
32
78
Western US
cPanel Access Level
DataCenter Provider
Hello @jndawson,

To update, CPANEL-7786 is now fixed. Please verify you are using the latest version of both OSCommerce and YaBB (Mod Note: Removed Specific Version Numbers), and let us know if the issue persists.

Thank you.
Hello,

Those versions are the most recent available (YaBB 2.3.1 and OSCommerce 2.3.4). I've been unable to reproduce this issue on a test system. Could you verify you are using cPanel version 58.0.31, and that uninstalling/installing the cPAddons doesn't resolve the issue? Also, if the issue persists, make sure you enable "Force Refresh of All cPAddons Site Software Sources".

Thank you.
What exactly are you trying to reproduce? As you noted and we confirmed, the issue was corrected. The only question we had was why did you use old version numbers (that you removed) for YaBB & OSCommerce.

If it happens again, we'll let you know.
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello @jndawson,

Thanks for the confirmation! I wasn't sure the issue was resolved on your system based on the earlier response, so I wanted to make sure it was working as expected.