The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CPaddons not showing under software/service on cpanel accounts

Discussion in 'General Discussion' started by devGOD, Mar 17, 2011.

  1. devGOD

    devGOD Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    I added (checked) wordpress under the WHM (Install cPAddons) but I do not see it when going to Software/Services section in a cpanel account.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are you using the default x3 theme on the account in question? If you are not, please try switching to the default x3 theme and check if it is working then.

    If you are using the default x3 theme, could you check for any errors in the cPanel error log upon visiting the Site Software section?

    Code:
    tail -f /usr/local/cpanel/logs/error_log
    Also, you are logging in as the cPanel user, correct? Because if you are not, the root and reseller user cannot see the cPAddons listed and you normally get a message like this upon visiting that area:

     
  3. devGOD

    devGOD Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Yes, x3 (default) theme is being used and i'm logged in as CPanel user and not WHM root...

    error log
    Code:
    [~]# tail -f /usr/local/cpanel/logs/error_log
            main::objget(undef) called at whostmgr/bin/whostmgr2 line 4746
            main::objcache() called at whostmgr/bin/whostmgr2 line 334
    Cpanel::IxHash: Warning, mangling data key obj which is longer than 64 bytes, us                                    ing safe_html_encode
    Cpanel::IxHash:  at /usr/local/cpanel/Whostmgr/LibShare.pm line 105
            main::objget(undef) called at whostmgr/bin/whostmgr2 line 4746
            main::objcache() called at whostmgr/bin/whostmgr2 line 334
    Cpanel::IxHash: Warning, mangling data key obj which is longer than 64 bytes, us                                    ing safe_html_encode
    Cpanel::IxHash:  at /usr/local/cpanel/Whostmgr/LibShare.pm line 105
            main::objget(undef) called at whostmgr/bin/whostmgr2 line 4746
            main::objcache() called at whostmgr/bin/whostmgr2 line 334
    
    
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please check the location of your perl binary:

    Code:
    ls -lah /usr/bin/perl /usr/local/bin/perl
    Also, are you logging in as the cPanel user for the account in question?
     
  5. devGOD

    devGOD Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Yes, i'm logged into the Cpanel user account in question. I've noticed that this is happening on all accounts.
    Code:
    ls -lah /usr/bin/perl /usr/local/bin/perl
    -rwxr-xr-x 2 root root 15K Mar 25  2009 /usr/bin/perl*
    lrwxrwxrwx 1 root root  13 Aug 27  2009 /usr/local/bin/perl -> /usr/bin/perl*
    
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Try the following commands:

    Code:
    mv /usr/bin/perl /usr/bin/perl.bak
    rm /usr/local/bin/perl
    cp /usr/bin/perl.bak /usr/local/bin/perl
    ln -s /usr/local/bin/perl /usr/bin/perl
    After doing the above exactly as noted, please then issue this command:

    Code:
    /scripts/checkperlmodules --full --force
     
  7. devGOD

    devGOD Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA

    ok everything installed expect ClamAV... I unchecked and rechecked Wordpress under CPaddons, logged out of the Cpanel user account and back in, and still now Wordpress press or any addons are being shown. What would the direct link look like for addon install in cpanel? Maybe i can try typing it in while logged into the Cpanel account to see if it generates any errors. is it something like http://www.site.com:2082/frontend/x3/module_installers/index.html?... ?

    Code:
      CPAN.pm: Going to build J/JA/JAMTUR/File-Scan-ClamAV-1.91.tar.gz
    
    Cannot find clamd in /root/bin (or a number of other places)
     - are you sure clamav in installed?
    No 'Makefile' created  JAMTUR/File-Scan-ClamAV-1.91.tar.gz
      /usr/local/bin/perl Makefile.PL -- NOT OK
    Running make install
      Make had some problems, won't install
    perlmod--Install done
    Notification => 00000@live.com via EMAIL [level => 1]
    Notification => 40400000@tmomail.net via PAGER [level => 1]
    Tested 137, 136 ok, 1 failed.
            Failed install: File::Scan::ClamAV
    Using fast module check.....checked 6 modules in 0 second(s)
    Cpanel::FastMath: [INSTALLED=1] [VERSION=0.3]
    Crypt::PasswdMD5::XS: [INSTALLED=1] [VERSION=0.3]
    Cpanel::POSIX::Tiny: [INSTALLED=1] [VERSION=1.1]
    Cpanel::Cleanup: [INSTALLED=1] [VERSION=0.4]
    Cpanel::Class: [INSTALLED=1] [VERSION=1.0.5]
    Cpanel::TaskQueue: [INSTALLED=1] [VERSION=0.307]
    
    
     
  8. devGOD

    devGOD Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
Loading...

Share This Page