cpAddons showing No Description Available

hostmedic

Well-Known Member
Apr 30, 2003
544
0
166
Washington Court House, Ohio, United States
cPanel Access Level
DataCenter Provider
This is a strange issue - I am hoping someone can give us a heads up ...

tail on the /usr/local/cpanel/logs/error_log shows:

Cpanel::cPAddons::cPAddons_init() called at (eval 16) line 1
eval 'Cpanel::cPAddons::cPAddons_init();' called at cpanel.pl line 3597
main::modloader('cPAddons') called at /usr/local/cpanel/Cpanel.pm line
240
Cpanel::loadmodule('cPAddons') called at cpanel.pl line 540
main::exectag('<cpanel cPAddons="mainpg(%FORM)">')
called at cpanel.pl line 3496
main::dotag(undef) called at cpanel.pl line 3410
main::parsehtml('GLOB(0x8ef7dd4)') called at cpanel.pl line 355
(internal death) Thu Apr 26 18:47:56 2007 [14510] error: Can't locate
auto/Cpanel/FileUtils/touchfile.al in @INC
ns: /usr/local/cpanel /usr/local/cpanel/cpaddons /usr/local/cpanel/perl
/usr/lib/perl5/5.6.2/i686-linux /usr/lib/
/usr/lib/perl5/site_perl/5.6.2/i686-linux /usr/lib/perl5/site_perl/5.6.2
/usr/lib/perl5/site_perl .) at /usr/loca
nel/cPAddons.pm line 2570
Carp::croak('Can\'t locate auto/Cpanel/FileUtils/touchfile.al in @INC
(@INC c...') called at /usr/lib/per
oLoader.pm line 104
AutoLoader::AUTOLOAD('/var/cpanel/cpaddons_moderated.yaml') called at
/usr/local/cpanel/Cpanel/cPAddons.p
Cpanel::cPAddons::_write_this('/var/cpanel/cpaddons_moderated.yaml',
'HASH(0x91e1180)') called at /usr/lo
panel/cPAddons.pm line 2564
Cpanel::cPAddons::_write_cache('/var/cpanel/cpaddons_moderated',
'HASH(0x91e1180)') called at /usr/local/
l/cPAddons.pm line 2521
Cpanel::cPAddons::_read_cache('/var/cpanel/cpaddons_moderated',
'HASH(0x9309588)') called at /usr/local/c
/cPAddons.pm line 79
Cpanel::cPAddons::cPAddons_init() called at (eval 23) line 1
eval 'Cpanel::cPAddons::cPAddons_init();' called at cpanel.pl line 3597
main::modloader('cPAddons') called at /usr/local/cpanel/Cpanel.pm line
240
Cpanel::loadmodule('cPAddons') called at cpanel.pl line 540
main::exectag('<cpanel cPAddons="mainpg(%FORM)">')
called at cpanel.pl line 3496
main::dotag(undef) called at cpanel.pl line 3410
main::parsehtml('GLOB(0x8ef7968)') called at cpanel.pl line 355

What we have tried:

1. scp from another cpanel server the entire /usr/local/cpanel/cpaddons
directory recursively

This did not fix the issue.

2. perform a /scripts/upcp --force

3. setup additional account -just in case it was account specific - it is not

4. Repetitive banging of the head against the wall - just bruises but no ideas or fixes have come forth yet... ;)


Please advise...

I have opened up a ticket as well: Support Request Id 188997

WHM 10.8.0 cPanel 10.9.0-S9966
CentOS 4.4 i686 - WHM X v3.1.0
 
Last edited:

tmvnews

Well-Known Member
Apr 5, 2002
128
0
316
Just incase you didn't get your answer I would attempt the following

Login to WHM Deselect all scripts you have installed

Login to SSH and do the following
rm -rf /usr/local/cpanel/cpaddons
./scripts/upcp --force

then login to whm and reselect your scripts
 

AlexV.

Well-Known Member
Jun 15, 2006
212
1
168
I just checked the ticket and his issue was resolved. :)

hostmedic:

If you have any further issues please feel free to contact us via the ticket system.
 

Sash

Well-Known Member
Feb 18, 2003
252
0
166
Alex,

Can you please tell me what the fix was to resolve the problem?

Thanks,
Mike