Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cpan -u don't know our perl version

Discussion in 'General Discussion' started by natong, Jan 21, 2016.

  1. natong

    natong Well-Known Member

    Joined:
    May 17, 2008
    Messages:
    89
    Likes Received:
    1
    Trophy Points:
    56
    I am using WHM 11.52.2 (build 4) and perl 5.8.8.
    When using command cpan -u or cpan -O, it doesn't know which is our perl version.
    It list and try to update to latest modules version of perl 5.22.1.

    Is these normal behavier?


    Code:
    root 05:02:02 PM /usr/lib 1057 # cpan -D FindBin
    Loading internal null logger. Install Log::Log4perl for logging messages
    CPAN: Storable loaded ok (v2.51)
    Reading '/home/.cpan/Metadata'
      Database was generated on Wed, 20 Jan 2016 06:41:03 GMT
    FindBin
    -------------------------------------------------------------------------
            Locate current script bin directory
            S/SH/SHAY/perl-5.22.1.tar.bz2
            /usr/lib/perl5/5.8.8/FindBin.pm
            Installed: 1.47
            CPAN:      1.51  Not up to date
            The Perl5 Porters Mailing List (P5P)
            perl5-porters@perl.org
     
    #1 natong, Jan 21, 2016
    Last edited: Jan 21, 2016
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,214
    Likes Received:
    1,936
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. natong

    natong Well-Known Member

    Joined:
    May 17, 2008
    Messages:
    89
    Likes Received:
    1
    Trophy Points:
    56
    I try to update all perl modules for 5.8.8.
    I think cpan -u command don't have a separate lists for each perl versions.
    cpan -u get the latest module version. Some of them are for perl 5.22.1 only.

    In WHM's Module Installers interface (Home >> Software >> Module Installers) too, some of them are for perl 5.22.1 and can't install.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,214
    Likes Received:
    1,936
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Could you elaborate on the specific issue you are facing? For instance, do you have a script with a required Perl module that's failing with a specific error message?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice