The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel 11.25 Security Tokens issue

Discussion in 'Security' started by sven4o, Jun 3, 2010.

  1. sven4o

    sven4o Member

    Joined:
    May 21, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    We have enabled Security Tokens on our servers after the upgrade to cPanel 11.25:

    cPanel 11.25

    Everything is operating normally, however, the WebMail Enable AutoLoad functionality is not working.

    It can be set but after the user logs out and then logs in again the cpsess string is changed and the chosen webmail client is not loaded automatically. The option to pick an webmail client for AutoLoad is enabled once again.

    Could you please advise on how to resolve the problem.
     
  2. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    0
    Hi Sven,

    Thanks for the report. I'll do some internal testing; in the meantime, could you let me know which build of 11.25.0 you're currently using? (STABLE, RELEASE, etc). Thank you.
     
  3. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    0
    Hi Sven,

    I've run a few quick tests;

    a) 11.25.1-B46217: I'm not able to reproduce this behaviour.
    b) 11.25.0-S45750: I'm not able to reproduce this behaviour.

    To confirm we're doing the same things here, I'm:

    a) enabling: WHM: Tweak Settings: Security:
    "Require security tokens for all interfaces. [...]"
    b) logging into webmail: https://x.x.x.x:2096/
    c) selecting "Enable Autoload" under Horde;
    d) setting a default timeout (8 seconds in my testing)
    e) logging out of webmail (https://x.x.x.x:2096/logout/)
    f) logging back into webmail (https://x.x.x.x:2096/)
    g) observing a successful auto-load of webmail.

    If you are still having issues, the following information will be useful, should you choose to open a support ticket with cPanel regarding this issue:

    a) reference this forum thread in your ticket;
    b) what build are you running?
    c) do you have any addons installed? (rvskin, whatever)

    If you've already opened a support ticket with cPanel regarding this issue, I'd appreciate a PM with the ticket ID. Thank you.
     

    Attached Files:

    #3 cPanelJamyn, Jun 3, 2010
    Last edited: Jun 3, 2010
  4. _Dejan_

    _Dejan_ Member

    Joined:
    Feb 24, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    I get sometime this error if:
    -Reboot Server
    -Upgrade CPanel (not allways)

    But closing(Don't save tabs!!!) Firefox and open it again fix issue and all work normaly... It effect on WEBMail&WHM.
     
  5. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    0
    Could you answer the 2 questions in my last reply please? What build are you running, and do you have any additional software installed like rvSkin, etc. If you can consistently reproduce this problem, I suggest opening a ticket describing exactly how to replicate the problem and an analyst will take a look. Thanks.
     
  6. _Dejan_

    _Dejan_ Member

    Joined:
    Feb 24, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    This has happen with STABLE 45750 build no using STABLE 46156 build but didn't receive error again.

    I have installed next plugins:
    ConfigServer Security&Firewall
    Configure ClamAV Scanner (clamavconnector)
    Mod Security

    As Im say this is not big problem because I can fix it with closing and reopening browser and has happen only few times(2-5x in last 2 months)...
     
  7. _Dejan_

    _Dejan_ Member

    Joined:
    Feb 24, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Today Im reproduce this error again. What Im do?
    1.)Yesterday Im have in two tabs opened two webmails(Diferent domains&account but same server), Im at cca. 15:30 close Firefox and save tabs.
    2.)Now at 6:45 Im open Firefox and tabs are loaded automaticly.
    3.)On both Tabs Im get cPanel WEBMAIL login page. Im write email and password and confirm and after that Im get error: Access Denied: Security Token Failure

    Reopening Tab's do not fix issue only closing Firefox and reopen it fix issue...
     
    #7 _Dejan_, Jun 9, 2010
    Last edited: Jun 9, 2010
  8. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I actually have this problem with AWStats, rest seems to work.

    Access Denied: Security Token Failure

    Request Info:
    Requested page: /awstats.pl
    Error message: security token missing


    cPanel 11.25.0-S46156 - WHM 11.25.0 - X 3.9
    CENTOS 4.8 i686

    Reproduced in bluelagoon and x themes.
     
  9. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The Bluelagoon and X themes are deprecated and are no longer being developed, and no troubleshooting of new features is done with them. Does the problem still happen if you use the X3 theme?

    If the Bluelagoon and/or X "look and feel" is desired, then use the X3 theme with the Bluelagoon or X skin. You can choose a skin by clicking "Change Style" in an account's cPanel using X3.
     
  10. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Thanks! Switching to X3 solved the problem.
     
  11. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Important cPanel/WHM Version Number Designation Change

    Please Note: Important cPanel/WHM Version Number Designation Change

    As of July 28, 2010 the cPanel/WHM version number designations have been officially changed.

    Version 11.25.1 is now designated 11.28 and version 11.25.2 is now designated 11.30.

    These new changes were explained in some detail recently at the July 2010 - Quarterly Road map - Webinar direct from cPanel's PodCast Studio in Houston, Texas with speakers David Grega and Mario Rodriguez.

    An official press release about these changes is forthcoming and can be accessed at this link as soon as it's made available to the Forum Team:
    Important cPanel/WHM Version Number Designation Change (To be updated)

    This post serves to update users who are subscribed to threads (where this message is posted) looking forward to upcoming enhancements in future versions of cPanel.
     
Loading...

Share This Page