Cpanel 11.40 SDK hook breakage question

jhawkins002

Member
Mar 29, 2010
8
0
51
Hi all -

So we use the WHM sdk hooks to perform various essential post-account-creation maintenance items (pertinent documentation here). Today we upgraded two non-production servers to 11.40 and we immediately noticed our script hooks were no longer completely working. After some digging we discovered the 'post' account modify item 'newuser' is no longer supported in all cases - during account modification specifically.

Our dilemma is that we had to more or less discover this through trial and error in testing - as this change is not reflected in the 11.40 changelog (unless you count 'General Improvements' -> 'Userdata handling improvements') or in the overall SDK hooks documentation referenced earlier.

Are there other avenues we should be keeping an eye on to monitor changes of this type? Greatful for any advice the devs or community can provide.
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,578
52
308
cPanel Access Level
Root Administrator
This sounds like a bug, not a deliberate change. I've asked the team that was last in that area of the product to examine your issue.
 

cPanelToddR

Member
Staff member
Oct 8, 2009
21
1
128
Hi all -

So we use the WHM sdk hooks to perform various essential post-account-creation maintenance items (pertinent documentation here). Today we upgraded two non-production servers to 11.40 and we immediately noticed our script hooks were no longer completely working. After some digging we discovered the 'post' account modify item 'newuser' is no longer supported in all cases - during account modification specifically.

Our dilemma is that we had to more or less discover this through trial and error in testing - as this change is not reflected in the 11.40 changelog (unless you count 'General Improvements' -> 'Userdata handling improvements') or in the overall SDK hooks documentation referenced earlier.

Are there other avenues we should be keeping an eye on to monitor changes of this type? Greatful for any advice the devs or community can provide.
This appears to have been a bug related to a refactor of the create/edit package/account screens. Be on the look out for case 81325 as a fix for this.

Todd