The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel 11.52 - Can't switch to Retro style

Discussion in 'User Experience' started by Legendary, Oct 13, 2015.

  1. Legendary

    Legendary Member

    Joined:
    Aug 13, 2015
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    US
    cPanel Access Level:
    Root Administrator
    I'm currently testing 11.52 and I'm getting an error when trying to switch the style to "Retro."

    "The system failed to apply the style you selected."

    Any ideas?
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Is there anything in the cPanel error log when this occurs?
     
  3. cPanelAdamF

    cPanelAdamF cPanel Product Owner
    Staff Member

    Joined:
    Mar 21, 2013
    Messages:
    174
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Houston TX
    cPanel Access Level:
    DataCenter Provider
    Twitter:

    Is the current_style symlink located in ~/var/cpanel/styled broken? If so, you can point it at /usr/local/cpanel/base/frontend/paper_lantern/styled/retro and that will manually set the retro style for that user.
     
  4. Legendary

    Legendary Member

    Joined:
    Aug 13, 2015
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Thanks guys. Issue was caused by CloudLinux's feature, I had to set the following options:

    fs.protected_symlinks_create = 0
    fs.protected_hardlinks_create = 0

    Edit: Changing the styles' group to linksafe also works.
     
    #4 Legendary, Oct 13, 2015
    Last edited: Oct 13, 2015
Loading...

Share This Page