The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel 11 and apache question

Discussion in 'EasyApache' started by bsasninja, May 28, 2007.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    I have two questions:

    1) With cpanel 11 can I have both versions of php running, ie: php 4.4.6 and php 5.2.0 cause now with version 10 of cpanel I´ve php 4.4.6 and some customers need php 5.2.0.
    And then when an account is created how do i set which version of php the domain will use?¿

    2) should i upgrade from apache 1.3.x to 2.x? Which is better 2.0 or 2.2 ?

    Thanks
     
    #1 bsasninja, May 28, 2007
    Last edited: May 28, 2007
  2. bpat1434

    bpat1434 Well-Known Member

    Joined:
    Oct 2, 2004
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Columbia, MD
    From what I've found, cPanel (using EasyApache) will not configure php4 and php5 right so that they run together. That being said, it is possible, but you'd have to do a manual install, and one of the PHPs would be run as a module, the other as a cgi/fastcgi program. I'm running Windows Vista with Apache 2.2 and php4 as module, php5 as cgi. I use .php5 for php5 parsing, and .php, .php3, .php4, .phtml for php4 parsing.

    As for apache 2.0 vs 2.2... 2.2 is another rework of the base code so what's compatible with 2.0 isn't compatible with 2.2 (in most cases). I find that many more people use 2.0 right now than 2.2, but I guess that's because of the compatibility. If you want php4 and php5, use 2.0. If you just want one or the other, use 2.2 as that is what will probably be the future of the project.
     
  3. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    If you go to apache 2 go for 2.0. There are still too many issues with 2.2 and it hasn't been tested as much as 2.0 assuming you will be using easyapache3
     
Loading...

Share This Page