The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel 11 does not support Perl 5.8.8 / phpMyAdmin 2.11.0

Discussion in 'Database Discussions' started by netmation, Aug 24, 2007.

  1. netmation

    netmation Member

    Joined:
    Sep 23, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    My hosting company would not upgrade my Perl 5.8.7 to 5.8.8 since they said Cpanel does not support it. Seems odd that 5.8.8 is recommended for Cpanel 11, which is what I am running. Also why won't Cpanel support the latest stable release of phpMyAdmin, 2.11.0? Here is the response from my hosting company....

    Perl, and phpMyAdmin are installed internally by cPanel and cPanel installs them that are latest supported by them. Upgrading their versions can corrupt or create problems for cPanel's binaries. I won't recommend to upgrade the version of Perl. Also 'phpMyAdmin' is installed by cPanel with the version that they support.

    Thanks for any help.
     
  2. DReade83

    DReade83 Well-Known Member

    Joined:
    Oct 20, 2006
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cheshire, UK
    They're right in saying phpMyAdmin is installed by cPanel, that's a fact. But it's a requirement for them to upgrade your host to Perl 5.8.8.

    If I were you I'd tell them to upgrade Perl and, if they get stuck, contact cPanel Support - that's what it's there for. Apart from that though, the Perl installation is a doddle. There's a manual here: http://forums.cpanel.net/showthread.php?t=66166

    --
     
    #2 DReade83, Aug 24, 2007
    Last edited: Aug 24, 2007
  3. netmation

    netmation Member

    Joined:
    Sep 23, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Thanks got the Perl situation fixed. Could you help me understand phpMyAdmin. How can I tell what is the latest version Cpanel supports. I login to WHM on the root, click on phpMyAdmin in the Cpanel SQL Services section and get "Wrong username/password. Access denied.".

    Should I be able to upgrade phpMyAdmin myself in a VPS setup? Is there a site for Cpanel to show the latest supported versions of add-on packages?
     
  4. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    For your access issue, did you set a root mysql password in whm? That may be all you need.
     
  5. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    You should be able to install phpmyadmin yourself, even if you are just a basic user with no whm or shell access. phpmyadmin is just a standard php script. ftp it to your account, edit the config and its ready.
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The version of PHPMyAdmin integrated in cPanel is a couple versions old. We are working on updating it (along with other third party software) in the next build.
     
Loading...

Share This Page