The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel 11 - upcp is sleeping

Discussion in 'General Discussion' started by Website Rob, Jul 23, 2007.

  1. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Ok, after having problems with upgrading PHP from 4.x to 5.x on one particular Server, I decided that before I tried again I would first do a WHM update -- in case some things were missing. Lo and behold I watched with dread as I saw that the update had changed to an upgrade.

    From
    WHM 10.8.0 cPanel 10.9.0-R10737
    CentOS 3.8 i686 - WHM X v3.1.0

    To
    WHM 11.2.0 cPanel 11.6.0-R15076
    CENTOS Enterprise 3.8 i686 - WHM X v3.1.0


    For whatever reason, doing it through a Browser caused some Browser error msgs. that the connection had been lost -- then why did the update keep running? No matter, looked like an incomplete upgrade when it was done. Then decided to run "/scripts/upcp --force" but it (apparently) got stuck on "updating packages...".

    A quick check showed "upcp" now has Master / Slave processes -- what's that all about -- and both were Sleeping? I terminated both and restarted the update, again through a Browser. Currently they are Sleeping again and been running for about 2+ hrs., sitting at "0 Progress" and this line;

    Hostname Virtual Host is already setup
    ...Done


    Now I'm wondering, after reading many cPanel 11 upgrades/updates get bunged up and can take multiple attempts and/or hours to finish, do I just sit back and wait or ... ?

    Suggestions please.


    BTW, all services & sites "seem" to be operating correctly at this time.
     
  2. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    kill the updating process, yum, upcp, everything, and do an upcp --force. it happened to me and i fixed it with this thingie.
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Thanks for the reply, katmai.

    I ended up just rebooting the Server to clear out all the Sleeping process, of which there were mulitples related to updating, and started over. It frustrates me to no end when a forced update is done that requires prep-work but no mention of said prep-work beforehand.

    After the reboot and updating Perl and some modules that cPanel 11 needs, although, why the installer for v11 doesn't do it I don't know, I was able to finish the upgrade.

    Whole 'nother story regarding maildir update as that got hung-up also. In one Shell window in showed as running whilst in another, seperate Shell window, it showed as Sleeping.

    The above were various parts of the problem and eventually, all was solved.


    Now, if I could just get EasyApache to properly upgrade from 4.4.7 to 5.x, life would be good again. :)
     
Loading...

Share This Page