In Progress [CPANEL-14652] Make Primary link fails on Manage SSL Sites

kitchin

Member
Sep 18, 2011
24
0
51
cPanel Access Level
Root Administrator
[I have seen this bug on cPanel 68.0.23, with and without WHM access, with and without root. Two different ISP's. Seems to be broken Javascript.]

On a cPanel with add-on domains, the page SSL/TLS has a link to "Manage SSL Sites". It displays a grid of FQDN's and shows which one is "Primary." The column "SNI Required" is "No" for that one.

There is link for "Make Primary" on the other FQDN's. It's a Javascript link that fails, as far as I can tell. The workaround is to click "Uninstall Certificate" on the Primary. Then another FQDN gets designated Primary. When you get the right FQDN set as Primary, you can go to the Let's Encrypt page and click "Run AutoSSL" to get SSL back on all the domains. It's slow but has a spinner and has always completed for me.

Another bug:
The doc link "SSL Installation Workflow" on "Manage SSL Sites" is 404. The closest doc to my issue is The SSL Installation and Precedence Logic - cPanel Knowledge Base - cPanel Documentation

Notes:

* The doc may be wrong. The way it talks about "vhost" seems to match the misunderstanding I got from tech support at one of my ISP's.

* Tech support there was confused about "Primary", thinking it meant which domain was not an add-on. Well, the cPanel main page does say "Primary Domain" on the top right corner (default theme), and that has a different meaning than on the SSL page.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,912
2,241
363
Hello,

Internal case CPANEL-14652 is open to address an issue where the "Make Primary" action at "cPanel >> SSL/TLS >> Manage SSL Sites" does not function when you click on it. I'll monitor this case and update this thread with more information as it becomes available.

Another bug:
The doc link "SSL Installation Workflow" on "Manage SSL Sites" is 404. The closest doc to my issue is The SSL Installation and Precedence Logic - cPanel Knowledge Base - cPanel Documentation
I've opened internal case DOC-10195 to have the destination of that link corrected so that it points to:

The SSL Installation and Precedence Logic - cPanel Knowledge Base - cPanel Documentation

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,912
2,241
363
Hello,

To update on internal case DOC-10195, the link destination is now corrected.

Thank you.
 

janipewter

Active Member
Jan 2, 2013
44
3
8
cPanel Access Level
Root Administrator
When an account has multiple domains with SSL available, there is an option to set one as primary, presumably so that domain does not require visiting clients to support SNI in order to access it.

However when clicking the "make primary" link, nothing happens. Tested in Chrome and Firefox; same result.

Another thread on here from Jan 18 seems to suggest this bug has been fixed, but it is still present in v78
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,912
2,241
363
Hello @janipewter,

I've merged your post into this thread. I don't have a time frame to report on the status of CPANEL-14652 at this time, but I'll update this thread as soon as new information is available.

Thank you.