SOLVED [CPANEL-20545] Exim sending email (-53) retry time not reached for any host

locki

Member
May 21, 2018
5
0
1
USA
cPanel Access Level
Root Administrator
I have a problem with some domain in WHM for sending email, only a few special domain names can not send email to any host(Gmail,Yahoo,...) (it is possible to receive)

But other domains are correct and there is no problem sending
Exim log:

2018-05-21 15:57:14 1fKix9-0007MU-FG H=alt4.gmail-smtp-in.l.google.com [74.125.199.26] Connection timed out
2018-05-21 15:57:14 1fKix9-0007MU-FG == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out
2018-05-21 15:57:35 1fKix9-0007MU-FG Sender identification U=exampledomain D=exampledomain.com [email protected]
2018-05-21 15:57:35 1fKix9-0007MU-FG == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (-53): retry time not reached for any host for 'gmail.co
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello @locki,

Are you able to connect to Gmail over port 25 using telnet on your server's command line? For example:

Code:
telnet alt4.gmail-smtp-in.l.google.com 25
It's possible your hosting provider has blocked outgoing traffic over port 25 to Gmail, in which case you'd need to contact them to request they lift that restriction.

Thank you.
 

locki

Member
May 21, 2018
5
0
1
USA
cPanel Access Level
Root Administrator
Hello @locki,

Are you able to connect to Gmail over port 25 using telnet on your server's command line? For example:

Code:
telnet alt4.gmail-smtp-in.l.google.com 25
It's possible your hosting provider has blocked outgoing traffic over port 25 to Gmail, in which case you'd need to contact them to request they lift that restriction.

Thank you.
Hi,
Yes I get connected to alt4.gmail-smtp-in.l.google.com
This problem occurred only for some domains and there is no possibility to send email not just Gmail but also the other emails ([email protected],Outlook )
Other domains on the server work and emails are well sent...
 

Dave_totaal

Registered
Apr 11, 2013
2
0
1
cPanel Access Level
Root Administrator
We are experiencing this issue also, spread across multiple servers and different domains.
This is not limited to gmail, but happens to multiple domains for example: mail-tester. com.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello,

It looks like the initial log output only shows the connection failure. Can you let us know the full output from /var/log/exim_mainlog for one of the affected messages? EX:

Code:
exigrep SUBJECT /var/log/exim_mainlog
Replace SUBJECT with the subject of a message that's unable to send to a remote server.

Thank you.
 

locki

Member
May 21, 2018
5
0
1
USA
cPanel Access Level
Root Administrator
Hello,

It looks like the initial log output only shows the connection failure. Can you let us know the full output from /var/log/exim_mainlog for one of the affected messages? EX:

Code:
exigrep SUBJECT /var/log/exim_mainlog
Replace SUBJECT with the subject of a message that's unable to send to a remote server.

Thank you.
Code:
2018-05-21 15:56:11 1fKix9-0007MU-FG <= [email protected] H=(ns1.example.com) [::1]:34394 P=esmtpa A=dovecot_login:[email protected] S=578 [email protected] T="tester" for [email protected]
2018-05-21 15:56:11 1fKix9-0007MU-FG Sender identification U=example D=example.com [email protected]
2018-05-21 15:56:11 1fKix9-0007MU-FG SMTP connection outbound 1526901971 1fKix9-0007MU-FG example.com [email protected]
2018-05-21 15:57:14 1fKix9-0007MU-FG H=alt4.gmail-smtp-in.l.google.com [74.125.199.26] Connection timed out
2018-05-21 15:57:14 1fKix9-0007MU-FG == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out
2018-05-21 15:57:35 1fKix9-0007MU-FG Sender identification U=example D=example.com [email protected]
2018-05-21 15:57:35 1fKix9-0007MU-FG == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (-53): retry time not reached for any host for 'gmail.com'
2018-05-21 16:59:13 1fKix9-0007MU-FG Sender identification U=example D=example.com [email protected]
2018-05-21 16:59:13 1fKix9-0007MU-FG == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (-53): retry time not reached for any host for 'gmail.com'
2018-05-21 17:48:28 1fKix9-0007MU-FG Sender identification U=example D=example.com [email protected]
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello,

Can you browse to WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor and let us know how the following options are configured?

Send mail from account's dedicated IP address
Reference /etc/mailhelo for outgoing SMTP HELO
Reference /etc/mailips for outgoing SMTP connections


Thank you.
 
  • Like
Reactions: locki

locki

Member
May 21, 2018
5
0
1
USA
cPanel Access Level
Root Administrator
Hello,

Can you browse to WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor and let us know how the following options are configured?

Send mail from account's dedicated IP address
Reference /etc/mailhelo for outgoing SMTP HELO
Reference /etc/mailips for outgoing SMTP connections


Thank you.
Hi cPanelMichael,
Send mail from account's dedicated IP address : ON
Reference /etc/mailhelo for outgoing SMTP HELO : OFF
Reference /etc/mailips for outgoing SMTP connections : OFF


When i changed Send mail from account's dedicated IP address to OFF the problem was fixed and emails were sent.
What is the root cause of this problem?

Thank you for your response.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello,

Internal case CPANEL-20545 is open to address an issue where the /etc/mailhelo file is incorrectly populated with a reseller's domain name in cases where account's are assigned a dedicated IP address and owned by a reseller. This happens with the following option is enabled in WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor:

Send mail from account's dedicated IP address

I'll monitor the case and update this thread once it's published. In the meantime, the workaround is to temporarily disable the following option in WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor:

Send mail from account’s dedicated IP address

Then, if you want to modify which IP address Exim uses for sending emails until a solution is published, you'd need to follow the instructions documented on the following link:

Manually configure Exim's outgoing IP addresses

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello @locki,

It's also possible this relates to another case, CPANEL-20348, where the /etc/mailips file is incorrectly populated with the IP address associated with the ethernet device configured with the The ethernet device onto which new IP addresses are added option in WHM >> Basic WebHost Manager® Setup instead of with the main shared IP address configured for the The IPv4 address (only one address) to use to set up shared IPv4 virtual hosts option.

Can you verify if that's the case on the affected system?

Thank you.
 

locki

Member
May 21, 2018
5
0
1
USA
cPanel Access Level
Root Administrator
Hello @locki,

It's also possible this relates to another case, CPANEL-20348, where the /etc/mailips file is incorrectly populated with the IP address associated with the ethernet device configured with the The ethernet device onto which new IP addresses are added option in WHM >> Basic WebHost Manager® Setup instead of with the main shared IP address configured for the The IPv4 address (only one address) to use to set up shared IPv4 virtual hosts option.

Can you verify if that's the case on the affected system?

Thank you.
Hi @cPanelMichael,
When I ON the settings again Send mail from account's dedicated IP address and check mailips file The domain was not on that list.
I manually added domain to mailips and mailhelo So then the problem was resolved and emails were sent

Do not do this automatically?

Thank you.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello @locki,

The /etc/mailips file should be automatically populated with domain names that are assigned dedicated IP addresses upon enabling the Send mail from account's dedicated IP address option. Are you sure domain names on your system are assigned dedicated IP addresses? If not, it's normal for the file to remain blank.

Thank you.
 

Samet Chan

Well-Known Member
Jun 24, 2016
359
32
103
cPanel Access Level
Root Administrator
Twitter