SOLVED [CPANEL-20849] MultiPHP INI Editor is slow in version 72

vacancy

Well-Known Member
Sep 20, 2012
542
214
93
Turkey
cPanel Access Level
Root Administrator
Hello

After updating the Cpanel version from v70 to v72, the multi php ini editor part in whm to work slowly.

When we save changes, there is a long wait.

version v72.0.4
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello @vacancy,

I've reproduced this behavior and opened internal case CPANEL-21412 to report the issue. I'll monitor this case and update this thread with more information as it becomes available.

Thank you.
 
  • Like
Reactions: vacancy

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

To update, it looks like this happens on systems where the ea-php$$-php-fpm RPM is installed and PHP-FPM is not enabled for any accounts configured to use that version of PHP. I'll update this thread again once the solution is published (note the case number is now CPANEL-20849). In the meantime, the temporary workaround is to remove the PHP-FPM RPM when no accounts use PHP-FPM on that PHP version. EX:

Code:
yum remove ea-php70-php-fpm
Thank you.
 
  • Like
Reactions: rpvw and vacancy

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

This is fixed in cPanel and WHM version 72.0.7:

Fixed case CPANEL-20849: Don't attempt restart of PHP-FPM pools that don't exist.

Thank you.
 
  • Like
Reactions: vacancy