SOLVED [CPANEL-21026] Include cPanel 70 as LTS version in WHM >> Update Preferences

akamaras

Member
Dec 16, 2009
23
1
53
I am using the LTS tier in all of my servers.
Right now the only available lts version is 62 that will reach eol in a few days.
When will 70 enter the lts tier ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hello @akamaras,

cPanel & WHM version 70 was made available to the LTS release tier on June 6th, 2018. However, it's not available in WHM >> Update Preferences as a LTS version on servers using cPanel & WHM version 62 due to an issue with the Update Preferences UI. We're planning to publish an update to cPanel & WHM version 62 (case CPANEL-21026) in the near future to address the issue. In the meantime, the workaround is to manually adjust the "CPANEL=" line in the /etc/cpupdate.conf file to the following:

Code:
CPANEL=11.70
Thank you.
 

akamaras

Member
Dec 16, 2009
23
1
53
Hi Michael and thank you for the quick answer.

FYI
I updated one server using the procedure you proposed and now, in update preferences it now shows "There are no Long Term Support releases available." (see attached image)
Please plan a fix for this as well.

Thank you
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hi Michael and thank you for the quick answer.

FYI
I updated one server using the procedure you proposed and now, in update preferences it now shows "There are no Long Term Support releases available." (see attached image)
Please plan a fix for this as well.
Hi @akamaras,

This is scheduled to be solved as well, and the existing internal case number is CPANEL-20915.

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hello,

To update, CPANEL-20915 was published to cPanel & WHM version 70.0.51 today:

Fixed case CPANEL-20915: Fix logic for getting LTS versions in update preferences page.

I'll update this thread again once case CPANEL-21026 is published to version 62.

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hello,

cPanel & WHM version 62.0.48 was published today and includes the case that solves the issue reported on this thread:

Fixed case CPANEL-21026: Fix logic for getting LTS versions in update preferences page.

Thank you.
 

akamaras

Member
Dec 16, 2009
23
1
53
Hi Michael

I will update my servers by editing cpupdate.conf
But I'm afraid the problem is not solved in 62.0.48
Still you can't chose any lts version
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hi Michael

I will update my servers by editing cpupdate.conf
But I'm afraid the problem is not solved in 62.0.48
Still you can't chose any lts version
Hello @akamaras,

It's working as expected on a test system running cPanel & WHM version 62.0.48:

update-preferences-62.png

Can you let us know the contents of the /etc/cpupdate.conf file on the affected system? EX:

Code:
cat /etc/cpupdate.conf
Here's how it looks on the test system:

Code:
# cat /etc/cpupdate.conf
CPANEL=11.62.0.48
RPMUP=manual
SARULESUP=daily
STAGING_DIR=/usr/local/cpanel
UPDATES=manual
Thank you.
 

akamaras

Member
Dec 16, 2009
23
1
53
Actually it is working :)
In older versions I was pressing on the version for the dropdown menu to appear, now you have to click specifically on the "down arrow"
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hi @akamaras,

I'm glad to see it's working. Thank you for updating us with the outcome.