SOLVED [CPANEL-21375] Inconsistent UI behavior with outgoing email account suspensions

sys_alex

Member
Apr 23, 2018
18
6
3
Spain, Galicia
cPanel Access Level
Root Administrator
Hello,

when suspending an email account outgoing mail ( not login, just outgoing ) it's no shown beside the account, as it it when suspended login or incoming email.

Even when using uapi ( uapi --user=XXXXXX Email list_pops) outgoing email suspension is not something that you can get.

Is the fact that an account has suspended outgoing email saved anywhere ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @sys_alex,

I've been unable to reproduce this behavior on a test system when suspending an individual email account via cPanel >> Email Accounts or using the following UAPI function:

UAPI Functions - Email::suspend_outgoing - Developer Documentation - cPanel Documentation

In both cases, it correctly shows "Send" under Suspensions next to the email account in the cPanel UI:

Screen Shot 2018-06-19 at 10.53.02 AM.png

Can you verify which version of cPanel & WHM is installed on your system? Do you notice any errors in /usr/local/cpanel/logs/error_log when suspending the individual email account?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
The thing is it's when reloading the page when that Send icon dissapears.

And no errors logged anywhere.
Can you verify which version of cPanel & WHM is installed on your system?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @sys_alex,

Could you open a support ticket so we can take a closer look at the affected system? You can post the ticket number here and I will link this thread to the ticket.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello,

To update, internal case CPANEL-21375 is now open to address inconsistent cPanel UI behavior with the suspension status for outgoing email addresses. I'll monitor this case and update this thread with more information as it becomes available.

Update: This was fixed in cPanel version 76.

Thank you.
 
  • Like
Reactions: sys_alex