Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED [CPANEL-22169] Pure-FTPd: Preserve disabled ForcePassiveIP when NAT is active

Discussion in 'General Discussion' started by batesy87, Sep 12, 2018.

Tags:
  1. batesy87

    batesy87 Registered

    Joined:
    Sep 11, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I have followed the steps to setup Passive FTP for pure-ftpd How to Enable FTP Passive Mode - cPanel Knowledge Base - cPanel Documentation

    After running the setup script I notice this line

    Updating FTP related RPMs
    warn [build_ftp_conf] Invalid ForcePassiveIP setting, switching to default of xxx.xxx.xxx.xxx

    However as per the guide my "local" file is setup as follows
    root [~]# cd /var/cpanel/conf/pureftpd
    root [/var/cpanel/conf/pureftpd]# cat local
    ForcePassiveIP: ~
    PassivePortRange: 49152 65534

    It seems to error on the ~ and set the default IP address from /var/cpanel/conf/pureftpd/main
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,350
    Likes Received:
    62
    Trophy Points:
    178
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Unless your server is NAT'd, simply comment out the ForcePassiveIP directive rather than trying to set it with the ~

    # ForcePassiveIP: 192.168.0.1

    PassivePortRange: 49152 65534

    I know what the instructions say, but I've never ran ForcePassiveIP: ~ . If the box isn't NATd, I just keep that directive commented out.

    Mike
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Internal case CPANEL-22169 is open to address an issue where configuring ForcePassiveIP using the instructions for NAT environments on this document doesn't work. I'll update this case again once the solution is published. In the meantime, workaround referenced in the previous post should help. Let me know if you have any questions.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    To update, this was fixed in cPanel & WHM version 76:

    Fixed case CPANEL-22169: Pure-FTPd: Preserve disabled ForcePassiveIP when NAT is active.

    You can monitor the following page to see when version 76 reaches each release tier:

    cPanel Release Highlights

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice