SOLVED [CPANEL-22332] Upgrade cPanel internal PHP to 7.2

speckados

Well-Known Member
Hi

System WHM/Cpanel using very older and obsolete version of PHP, 5.6.37

Code:
/usr/local/cpanel/3rdparty/bin/php-cgi -v
PHP 5.6.30 (cgi-fcgi) (built: Jun  5 2018 15:24:10)

I like use 7.0 (best if use 7.2)

Thre're a official method for install other version of internal php ?

Best regards
 
C

cPanelUser-Inactive

Guest
We're working on providing a PHP update in version 76, which should have a release on the EDGE tier soon!
 
C

cPanelUser-Inactive

Guest
Not yet, unfortunately. Once there is a release site you can see when we intend to move through the tiers, but that's about as close as we can get you. We are cautious with announcing timelines because we adjust for a number of different factors.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

To update, cPanel & WHM version 76 is now in the EDGE and CURRENT tiers and includes the new internal PHP version:

Implemented case CPANEL-22332: Update cPanel internal PHP to upstream version 7.2.7.

You can monitor the following page to see when version 76 reaches each release tier:

cPanel Release Highlights

Thank you.