SOLVED [CPANEL-23908] "authnlinks" errors during backups/transfers

Cyberbest

Member
Sep 18, 2008
10
1
53
In the last week or so I started to get errors in the nightly backup on a few servers. The error is:
[2018-11-10 02:01:55 -0800] Performing â[email protected]~\AuthnLinksâ[email protected]~] component....
[2018-11-10 02:01:55 -0800] The â[email protected]~\AuthnLinksâ[email protected]~] failed with an error: (XID 3ffatm) The system failed to open the directory â[email protected]~\authnlinksâ[email protected]~] because of an error: No such file or directory
[2018-11-10 02:01:55 -0800] Completed â[email protected]~\AuthnLinksâ[email protected]~] component.

I get it on the same sites every night. I can't find any files or directory for authnlinks on any sites, so I have no idea what is going on.

Luckily, we have received no complaints 'yet'!

Does anyone have any ideas? A search all over the Internet and this forum bring up nothing.

Joe
 

Cyberbest

Member
Sep 18, 2008
10
1
53
I posted this in the wrong place. I reposted this in the general area. I'm surprised I can't delete or even correct my own post. So please delete this message.
 

Cyberbest

Member
Sep 18, 2008
10
1
53
My cPanel reseller submitted a ticket. Quickly, cPanel support said:

"It looks like there was some user cruft for openid authentication on a few users in /var/cpanel/authn/links/users
After clearing this I was able to create backups on previous users that were getting the shown errors."

I guess this is now fixed, thank you. But it is strange that this happened on different servers the same night and then continued every night. I'm not sure if this was a side effect with a cPanle upgrade or just what. But if it's fixed, -- On with the show!.

Thank you cPanel for your excellent support

Joe
 
  • Like
Reactions: Infopro

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
Hello @Cyberbest,

It looks like support ticket 10709395 was opened to address this issue. I've asked our Technical Analysts to take an additional look to ensure this isn't an issue due to a change in version 76. I'll monitor the ticket and update this thread with the outcome.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
Hello,

To update, internal case CPANEL-23908 is open to track reports of the following error message during backups and transfers after the upgrade to cPanel & WHM version 76:

Code:
The “AuthnLinks” failed with an error: (XID 123456) The system failed to open the directory “authnlinks” because of an error: No such file or directory
I'll monitor this case and update this thread with more information as it becomes available.

Thank you.
 

cyberweb

Member
May 12, 2017
5
1
3
rasht
cPanel Access Level
Root Administrator
Hello,

To update, internal case CPANEL-23908 is open to track reports of the following error message during backups and transfers after the upgrade to cPanel & WHM version 76:

Code:
The “AuthnLinks” failed with an error: (XID 123456) The system failed to open the directory “authnlinks” because of an error: No such file or directory
I'll monitor this case and update this thread with more information as it becomes available.

Thank you.
hello
we have this issue for all of the users that their username is listed under /var/cpanel/authn/links when we want to make a backup by /scripts/pkgacct
we get :
[2018-11-23 13:04:54 +0330] Performing “AuthnLinks” component....
[2018-11-23 13:04:54 +0330] The “AuthnLinks” failed with an error: (XID hamzfj) The system failed to open the directory “authnlinks” because of an error: No such file or directory
[2018-11-23 13:04:54 +0330] Completed “AuthnLinks” component.

we get this error after upgrading to 76.0.8
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
Hello @cyberweb,

I don't have new information to report on the status of internal case CPANEL-23908 at this time, but the workaround in the meantime is to move the empty sub-directories under /var/cpanel/authn/links/users/ out of the way using commands like this:

Code:
mkdir /root/authn-backup
mv /var/cpanel/authn/links/users/cpuser123 /root/authn-backup/
Thank you.
 

Cyberbest

Member
Sep 18, 2008
10
1
53
Hello @cyberweb,

I don't have new information to report on the status of internal case CPANEL-23908 at this time, but the workaround in the meantime is to move the empty sub-directories under /var/cpanel/authn/links/users/ out of the way using commands like this:

Code:
mkdir /root/authn-backup
mv /var/cpanel/authn/links/users/cpuser123 /root/authn-backup/
Thank you.
One thing that might help here is all the users on 3 servers that had this error during backup are old users that came over from Ensim. We used the cPanel script to convert them over, years ago I seem to remember that if they had .htaccess files with .htpasswords, cPanel made symbolic links using the Ensim site number convention as opposed to the user id. Might be a coincidence, but interesting for sure.

Joe
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
One thing that might help here is all the users on 3 servers that had this error during backup are old users that came over from Ensim. We used the cPanel script to convert them over, years ago I seem to remember that if they had .htaccess files with .htpasswords, cPanel made symbolic links using the Ensim site number convention as opposed to the user id. Might be a coincidence, but interesting for sure.

Joe
Hi Joe,

I've added that information in the internal case to assist with the investigation.

Thanks for sharing!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
Hello Everyone,

To update, this is fixed in cPanel & WHM version 76.0.14:

Fixed case CPANEL-23908: Prevent pkgacct error when the source and target directory are empty.

You can learn more about our release tiers by clicking here and see which build is published to each release tier by clicking here.

Thanks!