Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED [CPANEL-25603] Update breaks MySQL configuration file when no quotes are added to 'sql_mode' value

Discussion in 'Database Discussion' started by newbiesysadmin, Apr 24, 2019.

Tags:
  1. newbiesysadmin

    newbiesysadmin Member

    Joined:
    Oct 26, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I know this thread is a little old, but I had the same problem this morning.

    I followed Michael's advice to check the my.conf file and found the second last line filled out with doublequotes eg """"""""""" - maybe a couple of hundred of them.

    I edited to remove, restarted the service and all was well, but why would the cpanel update add all these doublequotes to the config file?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @newbiesysadmin,

    I moved this post to a separate thread since it appears to relate to a separate issue.

    Can you confirm if your /etc/my.cnf file included the following line prior to the update?

    Code:
    sql_mode=
    If so, this is a known issue that occurs when quotes are are missing from the 'sql_mode' value in the system's /etc/my.cnf file. It's fixed in cPanel & WHM version 80:

    Fixed case CPANEL-25603: Ensure keys with null values are correctly handled when rebuilding /etc/my.cnf.

    Additionally, there's an open request to backport this case into cPanel & WHM version 78. I'll continue to monitor the case and update this thread with more information as it becomes available.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. newbiesysadmin

    newbiesysadmin Member

    Joined:
    Oct 26, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Michael
    Yes, you are correct. It does contain sql_mode=
    Should I edit it to read sql_mode="" ?
    I'm on 78.0.21
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @newbiesysadmin,

    Yes, the workaround until your system is on a version of cPanel & WHM with the fix is to add quotes to the configuration options with null values in the /etc/my.cnf file. EX:

    Code:
    sql_mode = ""
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. newbiesysadmin

    newbiesysadmin Member

    Joined:
    Oct 26, 2012
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks, Michael.
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    To update, the fix was backported into cPanel & WHM 78 as of version 78.0.23.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice