In Progress [CPANEL-25619] The system could not prune backups

Luis Mota

Member
Jun 1, 2015
18
1
3
Porto
cPanel Access Level
Reseller Owner
Hello guys, my problem is simple.
Everything works but I still get an error saying that "The system could not prune the "amazingfolder" (yesterday folder), but actually that folder don't exist anymore after the backup routine.

The first time I tried there was an error on some site (cpanel account) permissions and the system was unable to delete that folder but now everything is fixed and I still get the same error dispite the fact that everything goes fine, at least it seems to go.
 

Luis Mota

Member
Jun 1, 2015
18
1
3
Porto
cPanel Access Level
Reseller Owner
I think I found the problem "The system could not prune the “[_1]” directory due to an error."

Now I need to find "[_1]" directory -.-'

edit:
 
Last edited:

Luis Mota

Member
Jun 1, 2015
18
1
3
Porto
cPanel Access Level
Reseller Owner
I can't find this dir.
What is strange is that the error is displayed after the .master.meta sync

Code:
[2019-05-20 02:40:30 +0100] info [cpbackup_transporter] Upload attempt #1 starting for /backup/2019-05-20/accounts/.master.meta to backup_s3/2019-05-20/accounts/.master.meta for destination:  Nameofmybackupdestination
[2019-05-20 02:40:30 +0100] info [cpbackup_transporter] Successful incremental transfer of /backup/2019-05-20/accounts/.master.meta to backup_s3/2019-05-20/accounts/.master.meta for destination Nameofmybackupdestination
[2019-05-20 02:40:30 +0100] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
[2019-05-20 02:40:30 +0100] info [cpbackup_transporter] cpbackup_transporter - Waiting up to 299s for new tasks
[2019-05-20 02:40:31 +0100] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
[2019-05-20 02:40:31 +0100] info [cpbackup_transporter] cpbackup_transporter - Waiting up to 298s for new tasks
[2019-05-20 02:40:32 +0100] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
[2019-05-20 02:40:32 +0100] info [cpbackup_transporter] cpbackup_transporter - Waiting up to 297s for new tasks

( ... )

[2019-05-20 02:45:30 +0100] info [cpbackup_transporter] cpbackup_transporter - Waiting up to 0s for new tasks
[2019-05-20 02:45:31 +0100] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
[2019-05-20 02:45:31 +0100] info [cpbackup_transporter] cpbackup_transporter - Exiting - the queue has been emptied; no more work to do after waiting for 300s
[2019-05-20 02:45:31 +0100] info [cpbackup_transporter] cPanel Backup Transporter Queue Daemon is being stopped.
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] Initializing log file
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] cpbackup_transporter - parent starting
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] cpbackup_transporter - child starting
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] cPanel Backup Transporter Queue Daemon started.
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] cpbackup_transporter - started
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
[2019-05-20 02:47:46 +0100] info [cpbackup_transporter] cpbackup_transporter - Processing next task
[2019-05-20 02:47:47 +0100] info [cpbackup_transporter] Instantiating Object
[2019-05-20 02:47:47 +0100] info [cpbackup_transporter] Starting a "prune" operation on the "Nameofmybackupdestination" destination ID "usi2ESkroDPNCGkcqDUkoTvT".
[2019-05-20 02:47:47 +0100] info [cpbackup_transporter] Base path for destination is backup_s3/
[2019-05-20 02:47:47 +0100] info [cpbackup_transporter] Performing prune operation, retaining 1 items on:  Metodo Rsync - para incremental
[2019-05-20 02:47:48 +0100] info [cpbackup_transporter] Pruning backup directory:  backup_s3/2019-05-19, from Nameofmybackupdestination
[2019-05-20 02:54:46 +0100] info [cpbackup_transporter] ERROR: Pruning backup_s3/2019-05-19 from Nameofmybackupdestination:  ssh slave failed: timed out
[2019-05-20 02:54:46 +0100] info [cpbackup_transporter] The system could not prune the “[_1]” directory due to an error.
[2019-05-20 02:54:46 +0100] info [cpbackup_transporter] Read the go.cpanel.net/directorypruning documentation for solutions to successfully prune the directory.
[2019-05-20 02:54:46 +0100] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
 
Last edited:

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello,

To update, internal case CPANEL-25619 is open to address an issue where false backup pruning failures are reported when the rm command times out on the remote backup destination. The pruning itself should continue to succeed despite the errors reported in /usr/local/cpanel/logs/cpbackup_transporter.log.

I'll monitor the status of this case and update this thread for more information as it becomes available.

Thank you.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
I Have the same issue, any update of this?
Hello :)

There's no update to report at this time. I'll continue to monitor the case and update this thread with more information as it becomes available. Note the pruning itself should continue to succeed despite the errors reported in /usr/local/cpanel/logs/cpbackup_transporter.log.

Thank you.