Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED [CPANEL-26240] Autoresponder subject tags are unable to process certain characters

Discussion in 'E-mail Discussion' started by PizzaTimeLV, Mar 4, 2019.

  1. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    Hi all,

    I am having a problem with autoresponders who return %subject% field as:
    • "=?UTF-8?B?VGXFoXQ=?=" when using outlook and setting decoding to UTF-8
    • "=?windows-1257?Q?Te=F0t?=" when not changing any mail options from Thunderbird/Webmail/Outlook
    • "=?iso-8859-4?Q?Te=B9t?=" when using office 365 email
    when sending "Tešt".

    Problem does not happen when:
    1. I put "Test" in subject field instead of "Tešt".
    2. If I edit autoresponder settings and instead of %subject% use "Tešt"
    3. If I read emails thro IMB Verse which is andriod application.
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,476
    Likes Received:
    506
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @PizzaTimeLV

    Can you please provide a specific autoresponder example that can be used to replicate the error?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    I uploaded settings which are returning error i specified. Body text returns fine, only subject field returns broken if I use %Subject% and sent email has special Latvian characters.

    If I put special Latvian characters in Autoresponders Subject field, then email doesnt return the error.
     

    Attached Files:

  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,476
    Likes Received:
    506
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @PizzaTimeLV

    I tried this in the mac Mail client and wasn't able to replicate the issue, it sounds like something specific to the mail client in this instance rather than something that is occurring on the server.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    As we can see in uploaded Image, then no, Issue still exists on Mac Mail aswell

    Edit: turns out error also appears when autoresponder returns sender username which have special latvian characters

    Edit2: Looks like its problem with using any tags provided by autoresponder, please, I need any idea where to look, I can not find anything. :(
     

    Attached Files:

    #5 PizzaTimeLV, Mar 8, 2019
    Last edited: Mar 8, 2019
  6. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    Update: using cpanel on other mailserver doesn't have this error. Which setting should I check?
     
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @PizzaTimeLV,

    Can you open a support ticket so we can take a closer look at your system and see what's happening on that particular server? You can post the ticket number here and we'll link this thread to it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    Well, granting access to our server doesn't seem like an option here, can you give me hints where to look, which files are responsible for encoding/decoding or anything else?
    It was working fine 2 weeks ago.
     
  9. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    Update: Found that Cpanel which doesn't have this error is running 76th version while the one with error is running 78.0.16
     
  10. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    Update2: 3rd server which is also running c-panel version 78th has this error, I found out that the one with version 76 recently got roundcube updated from mysql to light sql, which might fix this error for 78th servers.
     
  11. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @PizzaTimeLV,

    I've reproduced this behavior on a test system running cPanel & WHM version 78 and opened internal case CPANEL-26240 to report the issue. I'll monitor this case and update this thread with more information as it becomes available.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. PizzaTimeLV

    PizzaTimeLV Member

    Joined:
    Mar 4, 2019
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lativa
    cPanel Access Level:
    Root Administrator
    Is there any update on this?
     
  13. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @PizzaTimeLV,

    The case remains open. I don't have a specific time frame to offer on the publication of a solution at this time, but I'll continue to monitor the case and update this thread as new information becomes available.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    332
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Els Ibarsos :: Comunitat Valenciana :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi.

    In one server my customer has problems with autoresponder.

    • CENTOS 6.10 kvm [srv116]
    • v80.0.18
    Characters -> UTF-8
    Subject: RE: %subject%

    If send this subject
    Hola es un camiḉoión

    Get this
    RE: =?UTF-8?B?SG9sYSBlcyB1biBjYW1p4biJb2nDs24=?=


    Apreciate help
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #14 speckados, Jul 1, 2019
    Last edited by a moderator: Jul 1, 2019
  15. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @speckados,

    I moved your post into this thread, as it relates to the case discussed here.

    A fix for CPANEL-26240 was moved to the review status internally as of this morning (CST). I'll update this thread with more information on it's publication status as it becomes available.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,549
    Likes Received:
    2,182
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice