Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

In Progress [CPANEL-26813] Mailman 2.1.27

Discussion in 'E-mail Discussion' started by albatroz, Apr 10, 2019.

  1. albatroz

    albatroz Well-Known Member

    Joined:
    Mar 6, 2003
    Messages:
    348
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    Virtual Orbis / Peru
    cPanel Access Level:
    Root Administrator
    One of my customers did run a vulnerability test against
    my VPS and discovered that CPanel uses version 2.1.27 of Mailman
    stating that it is quite old and vulnerable
    so he is wondering if we can update it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. rclemings

    rclemings Well-Known Member

    Joined:
    Nov 5, 2007
    Messages:
    48
    Likes Received:
    5
    Trophy Points:
    58
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @rclemings

    Understood, I spoke to some of the folks on the team responsible about this today and the EoL of Python 2.7 was brought up and I'm waiting on some further feedback on this. I can update here when I get more information. I've also opened CPANEL-26813 as an internal Improvement case to address this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 cPanelLauren, Apr 11, 2019
    Last edited: Apr 11, 2019
  5. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    168
    Likes Received:
    3
    Trophy Points:
    168
    I suspect cPanel will keep Python 2 and just backport security fixes to it as they do for some of the other "EOL" software. Upgrading Mailman 2 to version 2.1.29 should fix any security issues. I am not sure what the delay is in doing that. cPanel? Why hasn't Mailman 2 been updated to 2.1.29?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice