In Progress [CPANEL-27299] Unable to remove php-fpm?

vincentg

Well-Known Member
May 12, 2004
154
3
168
new york
When i remove php-fpm you can no longer change php versions for an account!

You get Error: (XID qe5xmr) The “ea-php72-php-fpm” service is not installed.

Is there a reason for this??
 

vincentg

Well-Known Member
May 12, 2004
154
3
168
new york
After reading through the docs we find you need to go to php manager to turn it off.
There you can remove php-fpm but it has to be installed for the versions it's enabled for.
So if you removed it in apache then you need to add it again at least for one version of php.
If you install it for one version and a account has lets say php 7.1 but you have it installed for 5.6 then you will need to switch the account to 5.6 - disable php-fpm and then switch it back to 7.1 - pain
Also the select all is not good at all.
We select all and the off button is grayed out.
We find that if the account has it turned off and you select it this is the problem.
So you have to only select those that have it turned on - pain!