SOLVED [CPANEL-27458] Needed system RPMs were not installed: ImageMagick-devel

Reado

Well-Known Member
Sep 8, 2009
220
8
68
United Kingdom
cPanel Access Level
Root Administrator
Since v80 was installed, every time UPCP updates (and especially does so successfully), it is accompanied by an email saying:

Sysup: Needed system RPMs were not installed: ImageMagick-devel

ImageMagick7 and ImageMagick7-devel are both installed, so installing ImageMagick-devel (which tries to install v6) would conflict with v7. This was never an issue with v78.
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,478
591
263
Houston
cPanel Access Level
DataCenter Provider
Hi @Reado

ImageMagick7 must be from an unsupported repository we are using the OS offered version which is 6.7.8.9:

Code:
[[email protected] ~]# yum search ImageMagick-devel
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 67.222.0.10
 * EA4-experimental: 67.222.0.10
 * cpanel-addons-production-feed: 67.222.0.10
 * cpanel-plugins: 67.222.0.10
 * base: centos.mirror.lstn.net
 * centosplus: mirror.jaleco.com
 * epel: mirror.compevo.com
 * extras: mirror.jaleco.com
 * updates: repo1.dal.innoscale.net
======================================================================= N/S matched: ImageMagick-devel ========================================================================
ImageMagick-devel.i686 : Library links and header files for ImageMagick app development
ImageMagick-devel.x86_64 : Library links and header files for ImageMagick app development

  Name and summary matches only, use "search all" for everything.
Code:
[[email protected] ~]# yum info Imagemagick-devel.x86_64
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 67.222.0.10
 * EA4-experimental: 67.222.0.10
 * cpanel-addons-production-feed: 67.222.0.10
 * cpanel-plugins: 67.222.0.10
 * base: centos.mirror.lstn.net
 * centosplus: mirror.jaleco.com
 * epel: mirror.compevo.com
 * extras: mirror.jaleco.com
 * updates: repo1.dal.innoscale.net
Installed Packages
Name        : ImageMagick-devel
Arch        : x86_64
Version     : 6.7.8.9
Release     : 16.el7_6
Size        : 435 k
Repo        : installed
From repo   : updates
Summary     : Library links and header files for ImageMagick app development
URL         : http://www.imagemagick.org/
License     : ImageMagick
Description : ImageMagick-devel contains the library links and header files you'll
            : need to develop ImageMagick applications. ImageMagick is an image
            : manipulation program.
            :
            : If you want to create applications that will use ImageMagick code or
            : APIs, you need to install ImageMagick-devel as well as ImageMagick.
            : You do not need to install it if you just want to use ImageMagick,
            : however.

This makes it conflict with what the cPanel update process is looking for. In v80 it appears that we require system version of this per CPANEL-25143 which can be found in our Changelogs here: 80 Change Log - Change Logs - cPanel Documentation
 

Reado

Well-Known Member
Sep 8, 2009
220
8
68
United Kingdom
cPanel Access Level
Root Administrator
Why does this check need to run in the first place? What in v80 requires the prerequisites to be installed?

ImageMagick v7 is installed using the remi repository, via YUM for easy management. This has been the case for a few years, but now all of a sudden it's a problem for what reason?
 

Reado

Well-Known Member
Sep 8, 2009
220
8
68
United Kingdom
cPanel Access Level
Root Administrator
You must be doing something wrong then because I currently have the imagick-3.4.4 extension installed using the EA-PHP73 PECL with ImageMagick v7. It's never been an issue until cPanel v80 was installed.

How can I stop this error from occurring please?
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,478
591
263
Houston
cPanel Access Level
DataCenter Provider
As far as I am aware, this isn't going to be able to be changed since updating is requiring the OS provided package - it was not an issue until it was required in v80 which I did explain already, but so that we can look further into it can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,478
591
263
Houston
cPanel Access Level
DataCenter Provider
Based on the outcome of the ticket, in the above example, the issue was specifically related to the version of Imagick-devel as I pointed out earlier in this thread. Here is an excerpt from one of the responses:

In reviewing the behavior, it appears to be specific to the ImageMagick7-devel package not matching the search string. In theory one could modify that .pm file, to search for the custom-installed package names. Note that the file would be overwritten within a given upcp run, but in theory shouldn't be until after the sysup function has already run. As such, you may want to try setting a post-upcp script to re-change the values within the .pm file may work.
Guide to Standardized Hooks - Script Hooks - Developer Documentation - cPanel Documentation

I have, however, opened an improvement case(CPANEL-27458), for a more version-agnostic search query to be used. Unfortunately, there is no estimated time for when this case might be published.
At the moment, in order to update if you're using ImageMagick7-devel, you'll either need to employ the workaround suggested in the response or use the OS supported package.
 

slim

Well-Known Member
May 27, 2004
51
1
158
Australia
cPanel Access Level
Root Administrator
I have this exact same issue - Updated to v80 and my servers report the same thing. My servers are stock cPanel/Cloudlinux/litespeed/jetbackup etc - no custom stuff other than these installed.
 

slavajacobson

Registered
Jun 4, 2019
2
0
1
Canada
cPanel Access Level
Root Administrator
Can you also show me the error you're receiving @slavajacobson because this issue should not be occurring with that version of ImageMagick
This is what we're getting in the e-mail every evening:

Code:
The system failed to update to the latest version of cPanel & WHM version 11.80 because it could not install basic requirements for cPanel & WHM. The specific failure was:

Sysup: Needed system RPMs were not installed: ImageMagick-devel
And this is part of the cpanel update log:
Code:
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] ---> Package ImageMagick-devel.x86_64 0:6.7.8.9-16.el7_6 will be installed
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] --> Processing Dependency: libMagickWand.so.5()(64bit) for package: ImageMagick-devel-6.7.8.9-16.el7_6.x86_64
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] --> Processing Dependency: libMagickCore.so.5()(64bit) for package: ImageMagick-devel-6.7.8.9-16.el7_6.x86_64
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] ---> Package elfutils-libelf.i686 0:0.172-2.el7 will be installed
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] ---> Package libattr.i686 0:2.4.46-13.el7 will be installed
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] --> Finished Dependency Resolution
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] Error: Package: ImageMagick-devel-6.7.8.9-16.el7_6.x86_64 (updates)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]  You could try using --skip-broken to work around the problem
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] Error: Package: ImageMagick-devel-6.7.8.9-16.el7_6.x86_64 (updates)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]  You could try running: rpm -Va --nofiles --nodigest
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] (XID fe3bcj) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf install ImageMagick-devel --disablerepo=epel” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf install ImageMagick-devel --disablerepo=epel” command (process 15074) reported error number 1 when it ended. : Error: Package: ImageMagick-devel-6.7.8.9-16.el7_6.x86_64 (updates)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Requires: libMagickWand.so.5()(64bit)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Available: ImageMagick-6.7.8.9-15.el7_2.x86_64 (base)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]                libMagickWand.so.5()(64bit)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Available: ImageMagick-6.7.8.9-16.el7_6.x86_64 (updates)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]                libMagickWand.so.5()(64bit)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Installed: ImageMagick-6.9.9-50.x86_64 (installed)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]                Not found
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] Error: Package: ImageMagick-devel-6.7.8.9-16.el7_6.x86_64 (updates)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Requires: libMagickCore.so.5()(64bit)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Available: ImageMagick-6.7.8.9-15.el7_2.x86_64 (base)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]                libMagickCore.so.5()(64bit)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Available: ImageMagick-6.7.8.9-16.el7_6.x86_64 (updates)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]                libMagickCore.so.5()(64bit)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]            Installed: ImageMagick-6.9.9-50.x86_64 (installed)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup]                Not found
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] checkyum version 22.3  (excludes: bind-chroot perl ruby)
[2019-06-04 21:49:20 -0400]      [/usr/local/cpanel/scripts/sysup] E Sysup: Needed system RPMs were not installed: ImageMagick-devel
[2019-06-04 21:49:20 -0400]    - Finished command `/usr/local/cpanel/scripts/sysup` in 14.852 seconds
[2019-06-04 21:49:20 -0400]    - Finished in 14.853 seconds
 

John W

Member
Aug 24, 2007
16
0
51
Orlando
I also have this same issue.
CENTOS 7.6

rpm -qa |grep ImageMagick
ImageMagick-devel-6.7.8.9-16.el7_6.x86_64
ImageMagick-6.7.8.9-16.el7_6.x86_64
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,478
591
263
Houston
cPanel Access Level
DataCenter Provider
Hi Guys,

For everyone in this thread, I have recently learned that the requirement for ImageMagick-devel (any version) is being removed, we added it in v80 but due to the number of issues being presented with it we're removing the requirement. The case CPANEL-27458 is awaiting final addition into the product and I'll update here as soon as it's available.
 
  • Like
Reactions: John W

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,902
2,227
363
cPanel Access Level
DataCenter Provider
Twitter