SOLVED [CPANEL-27686] Not receiving new account email notifications

snewton

Active Member
Aug 4, 2015
41
7
58
Redford, MI
cPanel Access Level
Root Administrator
I've upgraded to version 80 and now I am seeing email delays and just general weirdness.

When I create a new account (in WHMCS or even WHM directly), I am not receiving the typical new account email notification.

But, if I terminate the account, I immediately receive the account terminated email notification as well as the new account email notification I should have received when the account was created. It's kind of like it's stuck and being pushed though by the termination email notification.

All other cPanel email notifications appear to be working though, such as creating an addon domain, suspension/unsuspension, etc.

I've checked the mail logs and I can't see or find any issues.

Thoughts? Suggestions?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello @snewton,

Can you browse to the Notifications tab in WHM >> Contact Manager and verify the Account Creation notification type is set to an Importance level that should result in an email notification? If so, can you create a new account and monitor /var/log/exim_mainlog to see if a new entry is logged? EX:

1. Open a SSH session as root and run the following command:

Code:
tail -f /var/log/exim_mainlog
2. Create a new account via WHM and see what's logged to /var/log/exim_mainlog.

Thank you.
 

snewton

Active Member
Aug 4, 2015
41
7
58
Redford, MI
cPanel Access Level
Root Administrator
Hello @snewton,

Can you browse to the Notifications tab in WHM >> Contact Manager and verify the Account Creation notification type is set to an Importance level that should result in an email notification? If so, can you create a new account and monitor /var/log/exim_mainlog to see if a new entry is logged? EX:

1. Open a SSH session as root and run the following command:

Code:
tail -f /var/log/exim_mainlog
2. Create a new account via WHM and see what's logged to /var/log/exim_mainlog.

Thank you.
I checked the Notifications tab and Account Creation is set to "Low".

I tailed the exim_mainlog and created a test account and nothing regarding the account creation was logged.

What's weird though, is once I terminate the account, both the termination notification and the new account creation notification emails get sent.

I've looked at all related logs and every setting that could possibly be related and I can't find anything wrong.

And again, the only change that I've made recently was upgrading to version 80
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello @snewton,

Can you open a support ticket so we can take a closer look? You can post the ticket number here and we'll link this thread to it.

Thank you.
 

snewton

Active Member
Aug 4, 2015
41
7
58
Redford, MI
cPanel Access Level
Root Administrator
Just to update:

cPanel support staff has diagnosed the issue as an issue with something in the version 80 upgrade as they could not reproduce the issue in their test environment on version 78, but did on version 80.

An internal case has been opened: ID CPANEL-27686
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello @snewton,

Thank you for updating this thread with the outcome of the ticket. I'll monitor case CPANEL-27686 and update this thread with more information on the status of this case as it becomes available.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463