Pending Publication [CPANEL-28685] Webmail access fails with blank screen no error

bitpt

Member
Sep 28, 2006
8
0
151
login with https://www.domain.com/webmail fail, open a blank screen no errors in logs after update to V82.07 (Cloudlinux 6.10)
Work well with pop3 software access.
Turning off cphulkd or csf do nothing.
Anyone have a clue?
 
Last edited:

ahsmx

Registered
Apr 6, 2019
3
0
1
Mexico
cPanel Access Level
Root Administrator
Hi! Same issue here. Customers has been reporting they cannot see their emails at webmail. This happens since update to v82.07 (NOT CloudLinux). This issue happens to when update to v82.06 but that was solved with a restart, however I cannot be restarting the server often for obvious reasons. I already did the following:
  • There is no port issue (domain.tld/webmail or webmail.domain.tld present same issue)
  • I restarted PHP-MFP service
  • I restarted dovecot service
  • I restarted Mail Server
I attach the following image:
 

Attachments

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Everyone,

We are continuing to investigate this issue as part of internal case CPANEL-28685. I'll monitor the case and update this thread with more information as it becomes available.

We do not require additional support tickets to help reproduce the issue at this time.

The temporary workaround is to run the following commands:

Rich (BB code):
/scripts/restartsrv_cpanel_php_fpm --hard
/scripts/restartsrv_cpsrvd --hard
Thank you.
 
Last edited:

ahsmx

Registered
Apr 6, 2019
3
0
1
Mexico
cPanel Access Level
Root Administrator
Moderator Edit: Removed quote suggesting to open a defect report, as we currently have enough reports to analyze the cause of the issue.

Te request ID is: 13050885

For now I have had to restart the server and problem disappear, however the server has to be online 24/7
 
Last edited by a moderator:

bitpt

Member
Sep 28, 2006
8
0
151
Hi! Same issue here. Customers has been reporting they cannot see their emails at webmail. This happens since update to v82.07 (NOT CloudLinux). This issue happens to when update to v82.06 but that was solved with a restart, however I cannot be restarting the server often for obvious reasons. I already did the following:
  • There is no port issue (domain.tld/webmail or webmail.domain.tld present same issue)
  • I restarted PHP-MFP service
  • I restarted dovecot service
  • I restarted Mail Server
I attach the following image:
Same here(same image )...
I restart cPHulk, allow 579...
Restart Server....
Restart devocot
Restart exim
No log indication for login attempt in any logs
Same problem
open a ticket
ID: 13049805
ID: 13051301 (bug report)
 
Last edited:

bitpt

Member
Sep 28, 2006
8
0
151
Solved by support

" I believe simply toggling php-fpm will get the service back up and that's what i've done."
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Everyone,

We are continuing to investigate this issue as part of internal case CPANEL-28685. I'll monitor the case and update this thread with more information as it becomes available.

We do not require additional support tickets to help reproduce the issue at this time.

The temporary workaround is to run the following commands:

Rich (BB code):
/scripts/restartsrv_cpanel_php_fpm --hard
/scripts/restartsrv_cpsrvd --hard
Thank you.
 
Last edited:

kamello

Registered
Aug 8, 2019
1
0
1
Santiago
cPanel Access Level
Root Administrator
The webmail doesnt load. I apply the first command and it works
  • CENTOS 7.6 kvm [zoe]
  • v82.0.8

    the /usr/local/cpanel/logs/error_log:

    Code:
    [*][[email protected] ~]# tail -n 30 -f /usr/local/cpanel/logs/error_log
            Cpanel::Server::try_to_handle_request_with_fpm(Cpanel::Server=HASH(0x2f15950)) called at cpsrvd.pl line 7052
            eval {...} called at cpsrvd.pl line 7046
            cpanel::cpsrvd::cgiHandler("app", "php", "document", "./horde/index.php") called at cpsrvd.pl line 6875
            cpanel::cpsrvd::phpHandler("document", "./horde/index.php") called at cpsrvd.pl line 5981
            cpanel::cpsrvd::dodoc_webmaild() called at cpsrvd.pl line 1981
            cpanel::cpsrvd::dodoc(HASH(0x13b6d88)) called at cpsrvd.pl line 1722
            cpanel::cpsrvd::handle_one_connection(12) called at cpsrvd.pl line 1099
            cpanel::cpsrvd::script() called at cpsrvd.pl line 427: falling back to php-cgi: check /usr/local/cpanel/logs/php-fpm/error.log
    [2019-08-08 13:27:23 -0400] info [webmaild] Cpanel::Exception::IO::ReadError/(XID tf7dz8) The system failed to read up to [format_bytes,_1] froma file handle because of an error: Connection reset by peer
     at /usr/local/cpanel/Cpanel/CPAN/Net/FastCGI/IO.pm line 39.
            Cpanel::CPAN::Net::FastCGI::IO::read_record(GLOB(0x31ea248)) called at /usr/local/cpanel/Cpanel/Server/FastCGI.pm line 339
            Cpanel::Server::FastCGI::read(Cpanel::Server::FastCGI=HASH(0x32060e0), "", 850, 0) called at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 153
            Cpanel::Server::Handlers::SubProcess::_read_headers_from_subprocess_blocking(Cpanel::Server::Handlers::SubProcess=HASH(0x32056d8)) called at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 57
            Cpanel::Server::Handlers::SubProcess::handler(Cpanel::Server::Handlers::SubProcess=HASH(0x32056d8), "subprocess_name", "php:/usr/local/cpanel/base/horde/index.php", "subprocess_read_handle", Cpanel::Server::FastCGI=HASH(0x32060e0)) called at /usr/local/cpanel/Cpanel/Server.pm line2032
            Cpanel::Server::try_to_handle_request_with_fpm(Cpanel::Server=HASH(0x2f15950)) called at cpsrvd.pl line 7052
            eval {...} called at cpsrvd.pl line 7046
            cpanel::cpsrvd::cgiHandler("app", "php", "document", "./horde/index.php") called at cpsrvd.pl line 6875
            cpanel::cpsrvd::phpHandler("document", "./horde/index.php") called at cpsrvd.pl line 5981
            cpanel::cpsrvd::dodoc_webmaild() called at cpsrvd.pl line 1981
            cpanel::cpsrvd::dodoc(HASH(0x13b6d88)) called at cpsrvd.pl line 1722
            cpanel::cpsrvd::handle_one_connection(12) called at cpsrvd.pl line 1099
            cpanel::cpsrvd::script() called at cpsrvd.pl line 427: falling back to php-cgi: check /usr/local/cpanel/logs/php-fpm/error.log
    [2019-08-08 13:31:18 -0400] info [whostmgrd] Successfully verified signature for cpanel (key types: release).
    ==> cpsrvd 11.82.0.8 started
    ==> cpsrvd: loading security policy....Done
    ==> cpsrvd: Setting up SSL support ... Done
    ==> cpsrvd: transferred port bindings: 10,11,12,3,4,5,6,7,8,9
    ==> cpsrvd: bound to ports
    [2019-08-08 13:36:46 -0400] info [cpsrvd] version 11.82.0.8 online
    [2019-08-08 13:42:12 -0400] info [whostmgrd] Successfully verified signature for cpanel (key types: release).

 
Last edited by a moderator:

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Everyone,

We are continuing to investigate this issue as part of internal case CPANEL-28685. I'll monitor the case and update this thread with more information as it becomes available.

We do not require additional support tickets to help reproduce the issue at this time.

The temporary workaround is to run the following commands:

Rich (BB code):
/scripts/restartsrv_cpanel_php_fpm --hard
/scripts/restartsrv_cpsrvd --hard
Thank you.
 
Last edited:

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Everyone,

We are continuing to investigate this issue as part of internal case CPANEL-28685. I'll monitor the case and update this thread with more information as it becomes available.

We do not require additional support tickets to help reproduce the issue at this time.

The temporary workaround is to run the following commands:

Rich (BB code):
/scripts/restartsrv_cpanel_php_fpm --hard
/scripts/restartsrv_cpsrvd --hard
Thank you.
 
Last edited:

monkey64

Well-Known Member
Nov 6, 2011
100
4
68
cPanel Access Level
Root Administrator
I had exactly the same issue which was verified by a cPanel Technical Analyst within 1 hour. My ticket (13107321) was put through to level 3 senior analysts to review further. And then the trail went cold... I could wait no longer so I performed a Graceful Server Reboot and the webmail started working again! Problem solved.

I did eventually get a response from a level 3 senior analyst 21 hours later:

My apologies for any delay in our response. This particular issue (CPANEL-28685) is being actively investigated further by our Senior Technical Analysts and Developers to try and get a root cause analysis determined. It seems cPanel PHP-FPM may not be getting restarted properly following an update, and we wanted them to investigate the state of the issue before we resolve it.

We are glad to hear that the issue is resolved now. Should you have other servers experiencing this issue, it may be easier to try and resolve it with these commands:

/scripts/restartsrv_cpanel_php_fpm --hard
/scripts/restartsrv_cpsrvd --hard

Again we do apologize for the delay in our response and any inconvenience this issue may have caused. Please do let us know if you have any additional questions or concerns.

Best Regards

--
Ausaf Lateef
Linux Technical Analyst III
cPanel, L.L.C.
--
 
Last edited:

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Everyone,

Internal case CPANEL-28685 is still open at this time. I'll update this thread as soon as new information is available. In the meantime, the workaround noted in my earlier posts on this thread remain applicable.

Thank you.