[CPANEL-33877] Use transfert tool twice on a account with live option enable cause apache loop

youp

Well-Known Member
Oct 30, 2001
54
0
306
Hello,

Use transfert tool twice on a account with live option enable cause apache loop due to httpd.conf ProxyPass directive in the configuration ;(

is it possible to check this when we do that ?

Don't put the directive proxypass on the destination node when we do a transfert ...

Regards
 

andrew.n

Well-Known Member
Jun 9, 2020
266
54
28
EU
cPanel Access Level
Root Administrator
So you used the transfer tools twice to migrate an account from one server to another server which probably overwrote the account but I don't really understand the issue here. Can you elaborate?
 

youp

Well-Known Member
Oct 30, 2001
54
0
306
the first time you transfert an account, the transfert tool with live option put an extra configuration in httpd.conf on the remote server like this :


<Location "/">
ProxyPass "http://NEW.SERVER.COM/"
ProxyPreserveHost on
</Location>

if I restart a transfert , this configuration is applied on the new server , and cause a loop on apache ...

->
AH00286: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting


Regards
 

andrew.n

Well-Known Member
Jun 9, 2020
266
54
28
EU
cPanel Access Level
Root Administrator
Thanks for the clarification. Do you have root access to the server? You should make a manual cPanel backup and restore that on the destination server probably with Restricted Restore option enabled.
 

youp

Well-Known Member
Oct 30, 2001
54
0
306
probably , but it's something to check for the next release
 

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,237
1,232
313
Houston
There is already a case for this I found, CPANEL-33877 Live Transfer feature can lead to infinite proxy loop resulting in Apache DoS - Multi Server Variant - this issue is fixed in v92 and there is a request to push the fix to v90. I'll update here when that has been completed.


Thanks!
 

domaincolony

Registered
Aug 18, 2019
4
0
1
uk
cPanel Access Level
Root Administrator
I have the same issue after moving data centre but even more annoying now the licence has expired on the old server, can we get a grace period whilst this issue is unresolved please
 

youp

Well-Known Member
Oct 30, 2001
54
0
306
I have the same issue after moving data centre but even more annoying now the licence has expired on the old server, can we get a grace period whilst this issue is unresolved please
if you have the ssh access to your server , you can edit httpd.conf and delete the proxypass directive ...
 

domaincolony

Registered
Aug 18, 2019
4
0
1
uk
cPanel Access Level
Root Administrator
Can we have an update and solution please...? File/Directory Restore is still creating ProxyPass entries in httpd.conf - yes I can manually comment these lines out but this is a nightmare on server transfers.
 

VM Creativo

Member
Dec 8, 2018
8
7
3
Spain
cPanel Access Level
Root Administrator
Same here:

Apache config:
VirtualHost 1.2.3.4:8080 [1234:1234:0000:0000:1234:1234:1234:1234]:8080>
  ServerName client_domain.com
    ServerAlias ipv6.client_domain.com mail.client_domain.com www.client_domain.com
  <Location "/">
    ProxyPass "http://server.ourcompany.com/"
    ProxyPreserveHost on
  </Location>
  DocumentRoot /home/client_domain/public_html
  ServerAdmin [email protected]_domain.com
  UseCanonicalName Off

Is there any way to disable the further creation of ProxyPass?

I tried to comment on the httpd.conf file, but each time it is re-created it overwrites
 

domaincolony

Registered
Aug 18, 2019
4
0
1
uk
cPanel Access Level
Root Administrator
As changes to httpd.conf are not persistant - on each rebuild, add/remove domain the file is rewritten and the ProxyPas statement added/reactivated - can we have a timeline for resolution in whm v90, please
 

VM Creativo

Member
Dec 8, 2018
8
7
3
Spain
cPanel Access Level
Root Administrator
I have a temporary solution

Make a backup of the vhost creation template:

Bash:
cp /var/cpanel/templates/apache2_4/vhost.default /var/cpanel/templates/apache2_4/vhost.default.bak
Edit the vhost creation template:

Bash:
nano /var/cpanel/templates/apache2_4/vhost.default
Remove these lines

Perl:
[% IF vhost.proxy_backend -%]
  <Location "/">
    ProxyPass "http://[% vhost.proxy_backend %]/"
    ProxyPreserveHost on
  </Location>
[% END -%]
 

Bousaid Med

Registered
Sep 18, 2020
3
0
1
morocco
cPanel Access Level
Root Administrator
See my solution above, it has been working for 10 days without problems
-------------------------------


Thanks for your reply ,

please correct me if i'm wrong :


the solution is Removing these lines from vhost.default :

[% IF vhost.proxy_backend -%]
<Location "/">
ProxyPass "http://[% vhost.proxy_backend %]/"
ProxyPreserveHost on
</Location>
[% END -%]


this solution would work , but i have to delette the current account with probleme and re copy it another time ???


or it would work without deleting the current account with probleme ??

thanks.
 
Last edited:

drdoot

Registered
Aug 23, 2015
2
2
53
Hong Kong
cPanel Access Level
Website Owner
Facing the same problem here.

Frankly, I find it frustrating, as I do dry runs on transfers before doing the 'real' transfer.
The proxy thing with automatic suspending the account AND modifying .htaccess is not a positive IMO.

Turn it off by default
 
Last edited:

tmcstom

Member
Dec 31, 2014
20
3
53
cPanel Access Level
Root Administrator