SOLVED CPANEL-34807 - Update Composer to 2.0.6

amstel

Active Member
Nov 18, 2015
29
4
53
UK
cPanel Access Level
Root Administrator
Hi all,

Code:
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2
Code:
# rpm -qa |grep composer
cpanel-php-composer-1.8.6-1.cp1186.noarch
How I can upgrade composer to version 2.0 ?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
715
97
153
cPanel Access Level
Root Administrator
Hey there! Currently that is the most up-to-date version of Composer that is available. cPanel builds this version to work with all our software, and that is managed through the "/scripts/check_cpanel_rpms" tool.

I do see a recent feature request was opened for this just two months ago here: https://features.cpanel.net/topic/21911-update-composer-to-lastest-stable-version

but that doesn't seem to have received much action. In order to get that process started, I've opened case CPANEL-34807 so our devs can start working on this. Thanks for bringing this up!
 
  • Like
Reactions: amstel