In Progress CPANEL-40271 - MUNIN Plugin WARN: MySQL InnoDB free tablespace

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
I tested this on a version 102 system and the munin.conf file was created as part of the cron command that you mentioned. It wasn't created initially during the Munin install, but did appear as part of the cron.

Are you expecting the conf file to get created during the installation process?
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
cPRex i not expecting anything, only want to fix:
Munin shows "MySQL InnoDB free tablespace" critical alert

sudo -u munin /usr/local/cpanel/3rdparty/perl/532/bin/munin-cron (from here):

This article it's before year ago, and i get error, the issue in munin not fixing and still have error with:

"MySQL InnoDB free tablespace"

the funny thing is only in one server... one server is good so i start get confused, its impossible because both of my servers identical 100% even the websites inside each
one of them is identical in different language, but everything is identical.

AN UPDATE - I EDIT THE POST:
BTW I FOUND THIS:

I think maybe Munin install himself twice, and cPanel version 95 to 100.0 was change in the RPM or something.
i think i have 2 munin installation, it can happen to me, like this guy in the link i sent?
 
Last edited:

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
Ok first, thank you bro, i appriciate it a lot.

second i think i find solution how to turn this plugin off:

cPanel has updated and now created some:
cpanel.conf file inside the plugin-conf folder.

Its look like you have kind of 2 munin's or 2 set of configuration files.

Thos how i succeed to turn off the warning:

nano /etc/plugin-conf.d/cpanel.conf

then add this:

[mysql_innodb]
env.warning 0
env.critical 0

under the regular [mysql*]

but its not help by himself, i must do this as well:
i create file with nano:
nano /etc/munin/plugin-conf.d/mysql_innodb
with the contents:

[mysql_innodb]
env.warning 0
env.critical 0

Only then, warning disappear from Munin.
EVEN!
After Munin got fix, you can remove the line, but upgrade munin or reinstall it throw the interface, bring the error
back.

I suspect on DUPLICATED symlinks OR couple of configs cPanel created.
One belong to munin and one belong to cPanel and Munin TOGHTER. (costume config via cPanel)

i think have 2 systems, this why i must work with 2 config files
one is cpanel, conf
and the other is
mysql_innodb regular file in nano.

Now its work fine.
i sucssed to turn it off and the error not appear now.