Cpanel 6 still problem with reseller nameservers

O

ozzi4648

Guest
We gave one of our resellers his own nameservers and 2 ips

1.1.1.1.1 ns1.nameserver
2.2.2.2.2 ns2.nameserver

We add his nameservers Edit Reseller > Edit Reseller Privileges/Nameservers and add his ns1 and ns2 in the space provided. We then click on Assign ip address. The WRONG IP is retrieved. Trying to click on "Assign an (A) record for this nameserver does not add the (A) record. Instead it show the proper ip but no DNS record is create.

CRAP!

I go to DNS Zone and try to "Add a DNS Zone" Nothing, adding a DNS zone with the proper ip and proper nameserver name create some zone record from MARS. It wrong, totally wrong!

I need another drink because this is bullshit!

GET IT TOGETHER!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

Juanra

Well-Known Member
Sep 22, 2001
777
0
316
Spain
If I understood right, this is what I'd do in your case:

Edit your reseller's domain zone, add two NS records and the corresponding A records, so NS1 and NS2 will point to the IPs you preassigned.

Then, in the reseller center, set NS1.domain.com and NS2.domain.com as the reseller's nameservers - no need to assign IPs or adding A records, since you already did that - and save the changes.

And I think that's it.
 

FWC

Well-Known Member
May 13, 2002
354
0
316
Ontario, Canada
I did it a little differently. I added them manually to /etc/nameserverips. Then I added them in the Reseller Center, skipped assinging the IP's and added the A entries. WHM put them in the DNS zone for me. It seems to have worked.
 
O

ozzi4648

Guest
Yes, thanks that what i had to do to get it working. This was a problem with v5 as well and also a problem with v6 stable and Edge. Again i say "CAN WE GET THE BUGS FIXED"? There were so many bugs in v5 that were never fixed then they added a few new features, some of which dont work, and called is v6 and stable.