The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel 8.5 + some desasters

Discussion in 'General Discussion' started by HostyHost, Oct 31, 2003.

  1. HostyHost

    HostyHost Member

    Sep 23, 2003
    Likes Received:
    Trophy Points:
    I got cPanel version 8.5 installed via SSH on a new (factory configured) server running linux 9.0. I then ran into the following series of problems in sequence:

    1. the X windows wouldn't start by typing startx at the Linux prompt as soon as the installation of cPanel was completed(I get an error "Fatal server error: could not open default font 'fixed'".
    and the font server wouldn't start) - I checked my root directory space and I had plenty of free space left.

    >>>>>I then FIXED that by editing XF86Config:
    I comment out the line
    FontPath "tcp/localhost:7100"
    then I can start X just fine.

    2. Apache and Bind wouldn't start automatically and I have to start'em manually through WHM.

    3. when rebooting I get two errors (in red) one when closing the NIS server and another for closing another procedure..

    4. after I fixed the startx I updated my kernel to the latest version but it's consuming more space and I need to uninstall the old kernel and I don't know how??

    5. I get an RPC error that's filling the backgroung screen when I exit from x or Gnome, stating that it's an RPC error and it cannot find out what error this is...

    Do I need to format the drives and do a fresh install again or these errors could be due to some setting on WHM? I didn't do anything to get all these errors....
  2. mickeymouse

    mickeymouse Well-Known Member

    Sep 16, 2003
    Likes Received:
    Trophy Points:
    RE: cPanel 8.5 some desasters

    Dear HostyHost,

    Make sure that Bind and Apache are enabled in startup services. Check this using \"ntsysv\". Turn off the NIS server and see if that helps. To uninstall the old kernel follow these steps,

    1)You must copy the archive file of the Kernel to the /usr/src directory and move to this directory.
    #cp linux-version_tar.gz /usr/src/
    #cd /usr/src/
    These steps are required only if you already have installed a Linux kernel with a tar archive before.

    2)Remove the Linux symbolic link with the following command:
    #rm -f linux
    3)Remove the Linux kernel headers directory with the following command:

    #rm -rf linux-2.4.x/
    4)Remove the Linux kernel with the following command:
    #rm -f /boot/vmlinuz-2.4.x
    5)Remove the Linux file with the following command:
    #rm -f /boot/
    6)Remove the Linux kernel modules directory (if available) with the following command:
    #rm -rf /lib/modules/2.4.x/

    Removing the old kernel modules is only required if you have installed a modularized kernel version before. If the modules directory doesn.t exist under the /lib/modules directory, it\'s because your old kernel version is not a modularized kernel.

    Also,make sure that multiple X servers are running that sometimes causes RPC error.

    If you have any problem with this,then try to have a fresh installation with suitable requirements,that might help you to fix all your problems.

  3. netwrkr

    netwrkr Well-Known Member

    Apr 12, 2003
    Likes Received:
    Trophy Points:
    This is a -server- not a workstation. You shouldn't be running X.

Share This Page