Kingofwap

Registered
Sep 12, 2016
1
0
1
india
cPanel Access Level
Root Administrator
When i create a cpanel am getting error please let me know how to fix it.

Code:
unresolvable name: nameserver at /usr/local/cpanel/Cpanel/DnsRoots/Resolver.pm line 183.
at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Net/DNS/Resolver/Base.pm line 332.
    Net::DNS::Resolver::Base::nameservers(Net::DNS::Resolver::Base=HASH(0x701b938), "nameserver", "8.8.8.8") called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Net/DNS/Resolver/Base.pm line 256
    Net::DNS::Resolver::Base::_read_config_file(Net::DNS::Resolver::Base=HASH(0x701b938), "/etc/resolv.conf") called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Net/DNS/Resolver/UNIX.pm line 41
    Net::DNS::Resolver::UNIX::_init("Net::DNS::Resolver") called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Net/DNS/Resolver/Base.pm line 162
    Net::DNS::Resolver::Base::new("Net::DNS::Resolver", "debug", 0, "retry", 2, "udp_timeout", 3, "tcp_timeout", 3, ...) called at /usr/local/cpanel/Cpanel/DnsRoots/Resolver.pm line 183
    Cpanel::DnsRoots::Resolver::new("Cpanel::DnsRoots::Resolver") called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 140
    Cpanel::DnsRoots::_resolver() called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 46
    Cpanel::DnsRoots::new("Cpanel::DnsRoots") called at /usr/local/cpanel/Cpanel/DnsRoots.pm line 21
   
    Whostmgr::Accounts::Create::_wwwacct("featurelist", "default", "digestauth", "n", "bwlimit", 0, "contactemail", "", "homedir", ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1978
    Whostmgr::Accounts::Create::__createaccount("sign", "", "maxsql", "unlimited", "language", "en", "dkim", 1, "plan", ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 2028
    Whostmgr::Accounts::Create::_createaccount("sign", "", "maxsql", "unlimited", "language", "en", "dkim", 1, "plan", ...) called at whostmgr/bin
    main::wwwacct() called at whostmgr/bin/ line 229
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello,

Could you browse to "WHM Home » Server Configuration » Basic WebHost Manager® Setup" and ensure you have entered valid name servers under the "Nameservers" section at the bottom of the page? Also, check to ensure your /etc/resolv.conf file is using valid resolvers. Here's an example of how the contents of this file should look:

Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
Note that the IP addresses may vary, depending on which resolvers you use.

Thank you.