The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel account redirection to hostname

Discussion in 'General Discussion' started by TheM4ster, Aug 22, 2014.

  1. TheM4ster

    TheM4ster Member

    Joined:
    Aug 22, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello Everybody,

    I have a problem, whenever an entry cpanel account hosted on my vps, redirects me to the hostname.
    Example:

    domain.com/cpanel

    Redirect to:
    centos.domain.com:2083/

    That I can do to enter this way.
    domain.com:2083/

    Thank you, very much.

    TheM4ster
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can change the redirection settings under the "Redirection" tab in:

    "WHM Home » Server Configuration » Tweak Settings"

    Use "Origin Domain Name" instead of "Hostname" or "SSL Certificate Name".

    Thank you.
     
  3. TheM4ster

    TheM4ster Member

    Joined:
    Aug 22, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello cPanellMichael,
    I did as he tells me, now I have another problem,

    Redirect to:
    domain.com:2083/

    I get this error ssl,
    This Connection is Untrusted

    That I can do to enter this way and the next port.
    domain.com:2082/

    I have to do something more,

    ThankYou for answering
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, it's normal to see that warning because you can only install one SSL certificate per service via:

    "WHM Home » Service Configuration » Manage Service SSL Certificates"

    It defaults to a self-signed certificate that matches the hostname of the server. Any attempts to access it over an individual domain name will result in the SSL warning message (plus if it's self-signed there will be a warning anyway).

    Thank you.
     
  5. TheM4ster

    TheM4ster Member

    Joined:
    Aug 22, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,
    Ok,
    As I can avoid this redirection,

    Enter:
    domain.com/cpanel

    Redirect to:
    domain.com:2083/

    what I want is to enter the cpanel user account without SSL.
    Ejm:
    domain.com:2082/

    I did this and as usual,
    “Server Configuration >> Tweak Settings” >> “Require SSL” >> off.
    Please, as this is solved.

    Greetings
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    If "Always redirect to SSL" is disabled, then try clearing your browser cache to see if the redirect to the secure port still occurs.

    Thank you.
     
  7. TheM4ster

    TheM4ster Member

    Joined:
    Aug 22, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,
    remove the ssl correctly, thankyou,

    Now this happens,
    Enter:
    /http://www.domain.com/cpanel

    because before this redirect URL,
    /http://www.domain.com:2082/

    Redirect to:
    /http://www.domain.com:2082/unprotected/redirect.html

    which means, that, unprotected/redirect.html ?

    ThankYou,
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Make sure that "Require SSL" is also disabled under "Security" in "Tweak Settings" if you want to allow the use of the non-secure ports.

    Thank you.
     
Loading...

Share This Page