The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/cpanel always redirecting to :2083 even when the port is closed

Discussion in 'General Discussion' started by lauer, Dec 2, 2009.

  1. lauer

    lauer Member

    Joined:
    Aug 29, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I have two cpanel servers, and on the first when a customer is behind a firewall and tries to connect to the cpanel webinterface, he gets a "Detecting Your Internet Connection ...", where he can choose to be behind firewall.

    On the other server the redirection to the domain:2083 does happen in a second, which out give the customer a chance to choose to be behind a firewall.

    How can I get this webpage shown to all customers behind firewall on server two?

    Kind regards

    Jesper
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you double checked your redirection settings in WHM > Tweak Settings?
     
  3. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Check the redirection settings under

     
  4. lauer

    lauer Member

    Joined:
    Aug 29, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    The settings in redirection is the same on both servers.

    See the screenshot in the attached file.
     

    Attached Files:

  5. sp3ctre69

    sp3ctre69 Well-Known Member

    Joined:
    Aug 14, 2006
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    I know this is an old thread but I am having exactly the same problem with a brand new server. Settings for redirection are definitely the same on both servers. Does it depend on any other settings?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You want to allow users behind a firewall to access cPanel on the non secured (http) ports? What are your Redirection settings set to? You would not want to them to be Redirected to the SSL port I don't think.
     
  7. sp3ctre69

    sp3ctre69 Well-Known Member

    Joined:
    Aug 14, 2006
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    On the first server the settings are:

    Always redirect to SSL = On
    Non SSL redirect = Hostname
    SSL Redirect = Hostname

    When I set the new server to exactly the same it bahaves differently.

    On the first server it pops a screen saying "detecting your internet connection..." then gives me the option of SSL or not. On the second (new) server it just tries to connect to SSL and fails because the port is blocked.

    Just to clarify I want the "detecting your internet connection..." screen to be displayed on both servers.
     
  8. sp3ctre69

    sp3ctre69 Well-Known Member

    Joined:
    Aug 14, 2006
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    OK, found the answer I think....

    The page is not appearing on an old domain, but does on new ones... What is an SSL virtualhost, and how to I enable it on the domain in question?

    Thanks

    EDIT: scratch that, I was using a domain on the wrong box... still having the problem on new server :(
     
    #8 sp3ctre69, May 12, 2011
    Last edited: May 12, 2011
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hmm, login to cPanel here: yourdomain.com/cpanel/ once logged in, at bottom of the page theres a link to:

    "Reset All Interface Settings"

    Click that, then logout and clear your cache. I'm not clear if that has any effect on that detecting internet connection tool but it can't hurt to try that.

    Your issues sounds nothing like the OPs issue to me.
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Check these settings in WHM Server Configuration > Tweak Settings > Domains tab:
     

    Attached Files:

  11. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I would highly suggest also ensuring every setting is the same in WHM > Tweak Settings area for both machines. You can copy the /var/cpanel/cpanel.config file on the working machine, then copy it over to the non-working machine as cpanel.config.working to /var/cpanel, then do a diff on both files to see what is different in them:

    Code:
    diff /var/cpanel/cpanel.config /var/cpanel/cpanel.config.working
     
Loading...

Share This Page