The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel - an error occurred while processing this directive

Discussion in 'General Discussion' started by mydomain, Jan 9, 2005.

  1. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Need some assistance with an error message after users log into cPanel.

    After logging into cPanel for all users, all skins, the following error appears directly under the "Please update your contact information here" line:

    [an error occurred while processing this directive]

    [an error occurred while processing this directive]
    [an error occurred while processing this directive]

    The OS version is Cent OS 3.3 and its running the latest Current Build. Our other servers do not show this error running with the same build version.

    TIA
     
  2. TJCooper

    TJCooper Member

    Joined:
    Sep 21, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    St. Louis, MO
    I get the same error when logged into cpanel i am running WHM 9.9.9 cPanel 9.9.9-C120
    Fedora i686 - WHM X v3.1.0
     
  3. pupil

    pupil Member

    Joined:
    Jun 8, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    same problem here >>> :(
     
  4. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    I just went back down to the latest release version and its not appearing any more....can you guys try that also please to see if its the cpanel versions?
     
  5. pupil

    pupil Member

    Joined:
    Jun 8, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    this error arised with all current versions after the R-70, no one seems to have an idea what could be the reason... I have been searching in all forums for fixs ... for me I would prefer to be updated with the current versions .. hope smone can find solution.

    B.Rgds
     
  6. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Have you submitted a ticket to cPanel support? I have raised one and awaiting information back.
     
  7. pupil

    pupil Member

    Joined:
    Jun 8, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Not yet, assuming cPanel support is reading our posts :p ... will submit the ticket now and wait in the queue for reply :D
     
  8. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    I had the same problem a few months ago and it had to do with file permissions on the file:

    .contactemail


    They had been set at something other than username.username. See if the permissions are set at root.username. That is what caused my problem. I think I also ran a "touch" on it to update the file timestamp.
     
  9. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    Same here... www.domain.com/cpanel/ also does not work.... I have to do :2082. Running CentOS 3.3. .contactemail is set to username:username. I tried downgrading to Stable, but same thing. I'm also running PHP 4.9.10 & ran /scripts/installzendopt
     
  10. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    I too am getting this error with WHM 9.9.9 cPanel 9.9.9-R121 Fedora i686 - WHM X v3.1.0


    Swampy
     
  11. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    I submitted a ticket to cPanel... anyone find a solution yet???
     
  12. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    When you have it set to log errors and send the generic erro to the browser it gets logged in
    /usr/local/cpanel/log/error_log

    In ticket 86379 checking that led to seeing /etc/wwwacct.conf had bad permissions, now it works.
     
  13. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    Please always include your ticket number inposts like this, thanks
     
  14. WCW Fan

    WCW Fan Well-Known Member

    Joined:
    Sep 22, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Anyone know how to fix this ?
     
  15. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    make sure /etc/wwwacct.conf is chmod 644.
     
  16. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    I have checked the permissions on /etc/wwwacct.conf and they are 0644 but i still get this error in cpanel
     
  17. ampunboss

    ampunboss Member

    Joined:
    Jun 12, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    still problem here even i chmod 644 to /etc/wwwacct.conf
    Im using WHM 9.9.9 cPanel 9.9.9-R121 on RedHat Enterprise 3 i686.

    Older cpanel version seems ok.
     
  18. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    i just checked my logs and i had this error

    Code:
    (internal) Fri Jan 14 15:17:07 2005 [17886] warn: Main Shared IP is not configured at /usr/local/cpanel/Cpanel/DIp.pm line 81.
    	Cpanel::DIp::getmainip() called at /usr/local/cpanel/Cpanel/DIp.pm line 30
    	Cpanel::DIp::isdedicatedip(xx.xx.xx.xx) called at cpanel.pl line 3024
    	main::expvar('$isallowedssl') called at cpanel.pl line 766
    	main::execiftag('<cpanelif $isallowedssl>') called at cpanel.pl line 290
    	main::dotag(undef) called at cpanel.pl line 3410
    	main::parsehtml('GLOB(0x88db094)') called at cpanel.pl line 1618
    	main::doinclude('tables/advanced.html') called at cpanel.pl line 617
    	main::exectag('<cpanel include="tables/advanced.html">') called at cpanel.pl line 290
    	main::dotag(undef) called at cpanel.pl line 3410
    	main::parsehtml('GLOB(0x88ae470)') called at cpanel.pl line 284


    I checked my main shared ip and there was 2 ips xx.xx.xx.xx, xx.xx.xx.xx i removed the second ip and all is ok i used 2 ips with older stable and it was fine but with latest release only one ip works

    error has now gone hope this helps

    Swampy
     
  19. WCW Fan

    WCW Fan Well-Known Member

    Joined:
    Sep 22, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    That doesn't seem to have fixed it being as I only have one IP as the main ip :eek:
     
  20. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Same here, again the error log shows:

    Code:
    (internal) Fri Jan 14 20:29:15 2005 [2352] warn: Main Shared IP is not configured at /usr/local/cpanel/Cpanel/DIp.pm line 81.
            Cpanel::DIp::getmainip() called at /usr/local/cpanel/Cpanel/DIp.pm line 30
            Cpanel::DIp::isdedicatedip(xx.xx.xx.xx) called at cpanel.pl line 3024
            main::expvar('$isallowedssl') called at cpanel.pl line 766
            main::execiftag('<cpanelif $isallowedssl>') called at cpanel.pl line 290
            main::dotag(undef) called at cpanel.pl line 3410
            main::parsehtml('GLOB(0x88aeb08)') called at cpanel.pl line 284
    
    The R70 worked fine, now cPanel have introduced this bug into the current R121 - well done.

    Any ideas?
     
    #20 mydomain, Jan 14, 2005
    Last edited: Jan 14, 2005
Loading...

Share This Page