The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel and CentOS 3.4

Discussion in 'General Discussion' started by DigiCrime, Jun 9, 2005.

  1. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    Doing a fresh install or a reload, Downloaded centos from their website, choose server/text install, then go thru and do cpanel install everythings peachy cept one thing. DNS. When you reboot the server, dns doesnt start on its own youhave to manually start it (service named restart)

    I asked Cpanel about this, they said it was a bad CentOS install, but when you install Cpanel does it not download a version of bind from their website and cpanel script installs it? Either way its kind of anoying. Anyone else ran into this problem before? How can I edit the start up script to start named

    the script

    Code:
    #!/bin/bash
    #
    # named           This shell script takes care of starting and stopping
    #                 named (BIND DNS server).
    #
    # chkconfig: - 55 45
    # description: named (BIND) is a Domain Name Server (DNS) \
    # that is used to resolve host names to IP addresses.
    # probe: true
    
    # Source function library.
    . /etc/rc.d/init.d/functions
    
    # Source networking configuration.
    [ -r /etc/sysconfig/network ] && . /etc/sysconfig/network
    
    RETVAL=0
    prog="named"
    
    # Check that networking is up.
    [ "${NETWORKING}" = "no" ] && exit 0
    
    [ -r /etc/sysconfig/named ] && . /etc/sysconfig/named
    
    [ -x /usr/sbin/named ] || exit 0 
    
    [ -r ${ROOTDIR}/etc/named.conf ] || exit 0 
    
    
    start() {
            # Start daemons.
    	if [ -n "`/sbin/pidof named`" ]; then
    		echo -n $"$prog: already running"
    		return 1
    	fi
            echo -n $"Starting $prog: "
    	ckcf_options='';
    	if [ -n "${ROOTDIR}" -a "x${ROOTDIR}" != "x/" ]; then
    		OPTIONS="${OPTIONS} -t ${ROOTDIR}"
    		ckcf_options="-t ${ROOTDIR}";
    		if [ -s /etc/localtime ]; then
    		    cp -fp /etc/localtime ${ROOTDIR}/etc/localtime
    		fi;
    	fi
            conf_ok=0;
    	if [ -x /usr/sbin/named-checkconf ] && /usr/sbin/named-checkconf $ckcf_options; then
               conf_ok=1;
            else
    	   RETVAL=$?;
    	fi
    	if [ $conf_ok -eq 1 ]; then	   
    	   daemon /usr/sbin/named -u named ${OPTIONS};
    	   RETVAL=$?;
    	else
    	   named_err=`/usr/sbin/named -g 2>&1 | sed s/\n/\\n/g`;
    	   if [ `tty` != "/dev/console" ]; then
    	       echo -e "\n$named_err";
    	       echo -n  "Error in configuration file /etc/named.conf : ";
    	   fi;
               failure $"Error in configuration file /etc/named.conf : $named_err";
               echo
               return $RETVAL;
            fi;
     	[ $RETVAL -eq 0 ] && touch /var/lock/subsys/named 
            echo
    	return $RETVAL
    }
    stop() {
            # Stop daemons.
            echo -n $"Stopping $prog: "
    	/usr/sbin/rndc stop >/dev/null 2>&1
    	RETVAL=$?
    	[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/named || {
            	killproc named
    		RETVAL=$?
    		[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/named
    		echo
    		return $RETVAL 
    	}
    	success
            echo
    	return $RETVAL
    }
    rhstatus() {
    	/usr/sbin/rndc status
    	return $?
    }	
    restart() {
    	stop
    # wait a couple of seconds for the named to finish closing down
    	sleep 2
    	start
    }	
    reload() {
            echo -n $"Reloading $prog: "
    	p=`/sbin/pidof -o %PPID named`	
    	RETVAL=$?
    	if [ "$RETVAL" -eq 0 ]; then 
    	    /usr/sbin/rndc reload >/dev/null 2>&1 || /usr/bin/kill -HUP $p;
    	    RETVAL=$?
            fi
    	[ "$RETVAL" -eq 0 ] && success $"$prog reload" || failure $"$prog reload"
            echo
    	return $?
    }
    probe() {
    	# named knows how to reload intelligently; we don't want linuxconf
    	# to offer to restart every time
    	/usr/sbin/rndc reload >/dev/null 2>&1 || echo start
    	return $?
    }  
    
    # See how we were called.
    case "$1" in
    	start)
    		start
    		;;
    	stop)
    		stop
    		;;
    	status)
    		rhstatus
    		;;
    	restart)
    		restart
    		;;
    	condrestart)
    		if [ -e /var/lock/subsys/named ]; then restart; fi
    		;;
    	reload)
    		reload
    		;;
    	probe)
    		probe
    		;;
    	*)
            	echo $"Usage: $0 {start|stop|status|restart|condrestart|reload|probe}"
    		exit 1
    esac
    
    exit $?
    
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make sure that you go through WHM > Nameserver Setup then check that both bind and named are ticked in WHM > Service Manager.

    Just to be sure, then do:

    chkconfig named on

    It should now restart on failure and on boot.
     
  3. Tapan

    Tapan Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chandigarh
    Hi,

    I am not getting the bind checkbox in service manager what should i do ?

    Thanks.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    WHM > Nameserver Setup > OK
     
  5. Tapan

    Tapan Well-Known Member

    Joined:
    Dec 4, 2004
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chandigarh
    Hi,

    very thanks.

    Thanks.
     
Loading...

Share This Page